aboutsummaryrefslogtreecommitdiff
path: root/textproc/intltool
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2015-04-03 15:55:53 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2015-04-03 15:55:53 +0000
commit86931959a74093c8901378ee1ae12f8bfe35374b (patch)
treee49f2bffc0a03a3fbd85750a6789676a11b03fa0 /textproc/intltool
parent50455342fb59fb449d6ea861d9104b3fc7377407 (diff)
Notes
Diffstat (limited to 'textproc/intltool')
-rw-r--r--textproc/intltool/Makefile13
-rw-r--r--textproc/intltool/files/OrigTree.pm91
-rw-r--r--textproc/intltool/files/patch-intltool.m412
-rw-r--r--textproc/intltool/files/patch-intltoolize.in12
-rw-r--r--textproc/intltool/pkg-plist1
5 files changed, 25 insertions, 104 deletions
diff --git a/textproc/intltool/Makefile b/textproc/intltool/Makefile
index 9f5ff2041ae3..9e7df41a4aca 100644
--- a/textproc/intltool/Makefile
+++ b/textproc/intltool/Makefile
@@ -4,6 +4,7 @@
PORTNAME= intltool
PORTVERSION= 0.50.2
+PORTREVISION= 1
CATEGORIES= textproc gnome
MASTER_SITES= http://launchpadlibrarian.net/94524169/
DIST_SUBDIR= gnome
@@ -16,17 +17,5 @@ RUN_DEPENDS= p5-XML-Parser>=0:${PORTSDIR}/textproc/p5-XML-Parser
USES= iconv gmake perl5
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --libdir="${PREFIX}/libdata"
-
-CONFLICTS= xml-i18n-tools-[0-9]*
-
-post-patch:
- @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} \
- -E -e '/^mkinstalldirs[[:space:]]*=/s^/\.\.^^g'
-
-post-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/share/intltool/XML/Parser/Style
- ${INSTALL_DATA} ${FILESDIR}/OrigTree.pm \
- ${STAGEDIR}${PREFIX}/share/intltool/XML/Parser/Style
.include <bsd.port.mk>
diff --git a/textproc/intltool/files/OrigTree.pm b/textproc/intltool/files/OrigTree.pm
deleted file mode 100644
index 020400cfa35c..000000000000
--- a/textproc/intltool/files/OrigTree.pm
+++ /dev/null
@@ -1,91 +0,0 @@
-# $Id: OrigTree.pm,v 1.1 2003/11/26 15:18:28 kenneth Exp $
-
-package XML::Parser::Style::OrigTree;
-$XML::Parser::Built_In_Styles{OrigTree} = 1;
-
-sub Init {
- my $expat = shift;
- $expat->{Lists} = [];
- $expat->{Curlist} = $expat->{OrigTree} = [];
-}
-
-sub Start {
- my $expat = shift;
- my $tag = shift;
- my $newlist = [ { @_ } ];
- push @{ $expat->{Lists} }, $expat->{Curlist};
- push @{ $expat->{Curlist} }, $tag => $newlist;
- $expat->{Curlist} = $newlist;
-}
-
-sub End {
- my $expat = shift;
- my $tag = shift;
- $expat->{Curlist} = pop @{ $expat->{Lists} };
-}
-
-sub Char {
- my $expat = shift;
- my $text = shift;
- my $clist = $expat->{Curlist};
- my $pos = $#$clist;
-
- if ($pos > 0 and $clist->[$pos - 1] eq '0') {
- $clist->[$pos] .= $expat->original_string();
- } else {
- push @$clist, 0 => $expat->original_string();
- }
-}
-
-sub Final {
- my $expat = shift;
- delete $expat->{Curlist};
- delete $expat->{Lists};
- $expat->{OrigTree};
-}
-
-1;
-__END__
-
-=head1 NAME
-
-XML::Parser::Style::OrigTree
-
-=head1 SYNOPSIS
-
- use XML::Parser;
- my $p = XML::Parser->new(Style => 'OrigTree');
- my $tree = $p->parsefile('foo.xml');
-
-=head1 DESCRIPTION
-
-This module is a variant of the XML::Parser's Tree style parser. It
-uses original_string, so that Entities are not converted.
-
-When parsing a document, C<parse()> will return a parse tree for the
-document. Each node in the tree
-takes the form of a tag, content pair. Text nodes are represented with
-a pseudo-tag of "0" and the string that is their content. For elements,
-the content is an array reference. The first item in the array is a
-(possibly empty) hash reference containing attributes. The remainder of
-the array is a sequence of tag-content pairs representing the content
-of the element.
-
-So for example the result of parsing:
-
- <foo><head id="a">Hello <em>there</em></head><bar>Howdy<ref/></bar>do</foo>
-
-would be:
- Tag Content
- ==================================================================
- [foo, [{}, head, [{id => "a"}, 0, "Hello ", em, [{}, 0, "there"]],
- bar, [ {}, 0, "Howdy", ref, [{}]],
- 0, "do"
- ]
- ]
-
-The root document "foo", has 3 children: a "head" element, a "bar"
-element and the text "do". After the empty attribute hash, these are
-represented in it's contents by 3 tag-content pairs.
-
-=cut
diff --git a/textproc/intltool/files/patch-intltool.m4 b/textproc/intltool/files/patch-intltool.m4
new file mode 100644
index 000000000000..8df20c4a7201
--- /dev/null
+++ b/textproc/intltool/files/patch-intltool.m4
@@ -0,0 +1,12 @@
+--- intltool.m4.orig 2012-02-26 18:31:06 UTC
++++ intltool.m4
+@@ -164,6 +164,9 @@ if test -z "$DATADIRNAME"; then
+ return _nl_msg_cat_cntr]])],
+ [DATADIRNAME=share],
+ [case $host in
++ *-*-dragonfly*|*-*-freebsd*)
++ [DATADIRNAME=share]
++ ;;
+ *-*-solaris*)
+ dnl On Solaris, if bind_textdomain_codeset is in libc,
+ dnl GNU format message catalog is always supported,
diff --git a/textproc/intltool/files/patch-intltoolize.in b/textproc/intltool/files/patch-intltoolize.in
new file mode 100644
index 000000000000..d0910da1f8c0
--- /dev/null
+++ b/textproc/intltool/files/patch-intltoolize.in
@@ -0,0 +1,12 @@
+--- intltoolize.in.orig 2011-10-08 06:16:58 UTC
++++ intltoolize.in
+@@ -233,7 +233,8 @@ exit $status
+ # will be used to pull in the macro.
+ m4dir=`cat "$configure" | grep '^AC_CONFIG_MACRO_DIR' | sed -n -e 's/AC_CONFIG_MACRO_DIR(\([^()]*\))/\1/p' | sed -e 's/^\[\(.*\)\]$/\1/' | sed -e 1q`
+ if test -n "$m4dir"; then
+- rm -f $m4dir/intltool.m4
++ $mkdir -p $m4dir
++ $rm $m4dir/intltool.m4
+ if test -n "$ln_s" && $ln_s $intltool_m4 $m4dir/intltool.m4; then :
+ elif $cp $intltool_m4 $m4dir/intltool.m4; then :
+ else
diff --git a/textproc/intltool/pkg-plist b/textproc/intltool/pkg-plist
index a98fa295581a..6b753ed85f84 100644
--- a/textproc/intltool/pkg-plist
+++ b/textproc/intltool/pkg-plist
@@ -5,7 +5,6 @@ bin/intltool-update
bin/intltoolize
share/aclocal/intltool.m4
%%DATADIR%%/Makefile.in.in
-%%DATADIR%%/XML/Parser/Style/OrigTree.pm
man/man8/intltool-extract.8.gz
man/man8/intltool-merge.8.gz
man/man8/intltool-prepare.8.gz