aboutsummaryrefslogtreecommitdiff
path: root/textproc/isearch
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2002-12-15 03:08:32 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2002-12-15 03:08:32 +0000
commit0f4482c148c60efe6a25f5d0e336ba926eeeaf9f (patch)
tree39e184b43ed2a86b25f45f0bffb91b22cc240d86 /textproc/isearch
parent7eedb943e1768739e13a682f5fa0d31075361c79 (diff)
downloadports-0f4482c148c60efe6a25f5d0e336ba926eeeaf9f.tar.gz
ports-0f4482c148c60efe6a25f5d0e336ba926eeeaf9f.zip
Notes
Diffstat (limited to 'textproc/isearch')
-rw-r--r--textproc/isearch/Makefile8
-rw-r--r--textproc/isearch/files/patch-src::registry.hxx11
-rw-r--r--textproc/isearch/files/patch-src::string.cxx11
3 files changed, 23 insertions, 7 deletions
diff --git a/textproc/isearch/Makefile b/textproc/isearch/Makefile
index ab5a316377d7..9797cae44702 100644
--- a/textproc/isearch/Makefile
+++ b/textproc/isearch/Makefile
@@ -16,16 +16,10 @@ MAINTAINER= pmarquis@pobox.com
GNU_CONFIGURE= yes
MAKE_ARGS= INSTALL=${PREFIX}/bin
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 500035
-BROKEN= "Does not compile on 5.0"
-.endif
-
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/html/*.html ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/isearch/files/patch-src::registry.hxx b/textproc/isearch/files/patch-src::registry.hxx
new file mode 100644
index 000000000000..82245d37e0ac
--- /dev/null
+++ b/textproc/isearch/files/patch-src::registry.hxx
@@ -0,0 +1,11 @@
+--- src/registry.hxx.orig Sun Dec 15 09:13:27 2002
++++ src/registry.hxx Sun Dec 15 09:12:51 2002
+@@ -89,7 +89,7 @@
+ void LoadFromFile(const STRING& FileName);
+ void AddFromFile(const STRING& FileName);
+ // void Print(ostream& os, const INT Level) const;
+- void fprint(FILE* fp, const INT level = 0) const;
++ void fprint(FILE* fp, const INT level) const;
+ void ProfilePrint(ostream& os, const INT Level) const;
+ void GetData(STRLIST *StrlistBuffer);
+ void DeleteChildren();
diff --git a/textproc/isearch/files/patch-src::string.cxx b/textproc/isearch/files/patch-src::string.cxx
new file mode 100644
index 000000000000..784a3ac9cc14
--- /dev/null
+++ b/textproc/isearch/files/patch-src::string.cxx
@@ -0,0 +1,11 @@
+--- src/string.cxx.orig Sun Dec 15 09:27:00 2002
++++ src/string.cxx Sun Dec 15 09:27:20 2002
+@@ -574,7 +574,7 @@
+
+ // can this be const STRING& ?
+ ostream& operator<<(ostream& os, const STRING& str) {
+- os.write(str.Buffer, str.Length);
++ os.write((char*)str.Buffer, str.Length);
+ return os;
+ }
+