aboutsummaryrefslogtreecommitdiff
path: root/textproc/iso-schematron-xslt
diff options
context:
space:
mode:
authorGabor Kovesdan <gabor@FreeBSD.org>2013-03-13 10:22:23 +0000
committerGabor Kovesdan <gabor@FreeBSD.org>2013-03-13 10:22:23 +0000
commitef2ec338d8ea1e7a62561d18da39ca3d5f131471 (patch)
treea745d926b18c50587a5d3b7adfeaa71ca6333da0 /textproc/iso-schematron-xslt
parentfe285270c6d875648a19f5c6ea56ded8593fd35b (diff)
This is Rick Jelliffe's implementation of ISO Schematron using XSLT.
Notes
Notes: svn path=/head/; revision=314053
Diffstat (limited to 'textproc/iso-schematron-xslt')
-rw-r--r--textproc/iso-schematron-xslt/Makefile31
-rw-r--r--textproc/iso-schematron-xslt/distinfo4
-rw-r--r--textproc/iso-schematron-xslt/pkg-descr3
-rw-r--r--textproc/iso-schematron-xslt/pkg-plist27
4 files changed, 65 insertions, 0 deletions
diff --git a/textproc/iso-schematron-xslt/Makefile b/textproc/iso-schematron-xslt/Makefile
new file mode 100644
index 000000000000..1ba139295e49
--- /dev/null
+++ b/textproc/iso-schematron-xslt/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= iso-schematron-xslt
+PORTVERSION= 20130313
+CATEGORIES= textproc
+MASTER_SITES= http://www.schematron.com/tmp/
+DISTFILES= iso-schematron-xslt1.zip \
+ iso-schematron-xslt2.zip
+
+MAINTAINER= gabor@FreeBSD.org
+COMMENT= The Leading Implementation of ISO Schematron
+
+USE_ZIP= yes
+NO_BUILD= yes
+
+do-extract:
+ ${MKDIR} ${WRKDIR}/xslt1
+ ${MKDIR} ${WRKDIR}/xslt2
+ ( cd ${WRKDIR}/xslt1 && ${UNZIP_CMD} ${DISTDIR}/iso-schematron-xslt1.zip )
+ ( cd ${WRKDIR}/xslt2 && ${UNZIP_CMD} ${DISTDIR}/iso-schematron-xslt2.zip )
+
+INSTDIR= share/xsl/iso-schematron
+PLIST_SUB+= INSTDIR="${INSTDIR}"
+
+do-install:
+ ${MKDIR} ${PREFIX}/${INSTDIR}/xslt1
+ ( ${FIND} ${WRKDIR}/xslt1 -type f -exec ${INSTALL_DATA} {} ${PREFIX}/${INSTDIR}/xslt1/ \; )
+ ${MKDIR} ${PREFIX}/${INSTDIR}/xslt2
+ ( ${FIND} ${WRKDIR}/xslt2 -type f -exec ${INSTALL_DATA} {} ${PREFIX}/${INSTDIR}/xslt2/ \; )
+
+.include <bsd.port.mk>
diff --git a/textproc/iso-schematron-xslt/distinfo b/textproc/iso-schematron-xslt/distinfo
new file mode 100644
index 000000000000..cc8aee0b92d2
--- /dev/null
+++ b/textproc/iso-schematron-xslt/distinfo
@@ -0,0 +1,4 @@
+SHA256 (iso-schematron-xslt1.zip) = 0c2947e968dfcbbaa457b93b3140a5d25ea32c012864017af2cf3fb24cd20b4c
+SIZE (iso-schematron-xslt1.zip) = 44262
+SHA256 (iso-schematron-xslt2.zip) = b25f16ca7111d61f85ae660f1464016e9fb0ba1b7edd618fbf05200f82823ab9
+SIZE (iso-schematron-xslt2.zip) = 56092
diff --git a/textproc/iso-schematron-xslt/pkg-descr b/textproc/iso-schematron-xslt/pkg-descr
new file mode 100644
index 000000000000..9e4880f1326b
--- /dev/null
+++ b/textproc/iso-schematron-xslt/pkg-descr
@@ -0,0 +1,3 @@
+This is Rick Jelliffe's implementation of ISO Schematron using XSLT.
+
+WWW: http://www.schematron.com/implementation.html
diff --git a/textproc/iso-schematron-xslt/pkg-plist b/textproc/iso-schematron-xslt/pkg-plist
new file mode 100644
index 000000000000..8c2d723ffee3
--- /dev/null
+++ b/textproc/iso-schematron-xslt/pkg-plist
@@ -0,0 +1,27 @@
+%%INSTDIR%%/xslt1/ExtractSchFromRNG.xsl
+%%INSTDIR%%/xslt1/ExtractSchFromXSD.xsl
+%%INSTDIR%%/xslt1/iso_abstract_expand.xsl
+%%INSTDIR%%/xslt1/iso_dsdl_include.xsl
+%%INSTDIR%%/xslt1/iso_schematron_message.xsl
+%%INSTDIR%%/xslt1/iso_schematron_skeleton_for_xslt1.xsl
+%%INSTDIR%%/xslt1/iso_svrl_for_xslt1.xsl
+%%INSTDIR%%/xslt1/readme.txt
+%%INSTDIR%%/xslt1/schematron-skeleton-api.htm
+%%INSTDIR%%/xslt2/ExtractSchFromRNG-2.xsl
+%%INSTDIR%%/xslt2/ExtractSchFromXSD-2.xsl
+%%INSTDIR%%/xslt2/iso_abstract_expand.xsl
+%%INSTDIR%%/xslt2/iso_dsdl_include.xsl
+%%INSTDIR%%/xslt2/iso_schematron_message_xslt2.xsl
+%%INSTDIR%%/xslt2/iso_schematron_skeleton_for_saxon.xsl
+%%INSTDIR%%/xslt2/iso_svrl_for_xslt2.xsl
+%%INSTDIR%%/xslt2/readme.txt
+%%INSTDIR%%/xslt2/sch-messages-cs.xhtml
+%%INSTDIR%%/xslt2/sch-messages-de.xhtml
+%%INSTDIR%%/xslt2/sch-messages-en.xhtml
+%%INSTDIR%%/xslt2/sch-messages-fr.xhtml
+%%INSTDIR%%/xslt2/sch-messages-nl.xhtml
+%%INSTDIR%%/xslt2/schematron-skeleton-api.htm
+@dirrm %%INSTDIR%%/xslt1
+@dirrm %%INSTDIR%%/xslt2
+@dirrm %%INSTDIR%%
+@dirrmtry %D/share/xsl