aboutsummaryrefslogtreecommitdiff
path: root/textproc/ispell
diff options
context:
space:
mode:
authorJean-Marc Zucconi <jmz@FreeBSD.org>2002-02-21 20:22:59 +0000
committerJean-Marc Zucconi <jmz@FreeBSD.org>2002-02-21 20:22:59 +0000
commitba9f8d63ed3061fd9c004937d73870212a7a7e79 (patch)
treebfe5a947d50204981a4117e9943aa234e562d323 /textproc/ispell
parentdfdf0d65e09dc81aee05003da0a8e37c2cd02928 (diff)
Notes
Diffstat (limited to 'textproc/ispell')
-rw-r--r--textproc/ispell/Makefile2
-rw-r--r--textproc/ispell/files/patch-ac12
2 files changed, 13 insertions, 1 deletions
diff --git a/textproc/ispell/Makefile b/textproc/ispell/Makefile
index 575f553b3555..445be1b4002b 100644
--- a/textproc/ispell/Makefile
+++ b/textproc/ispell/Makefile
@@ -7,7 +7,7 @@
PORTNAME?= ispell
PORTVERSION?= 3.2.06
-PORTREVISION?= 0
+PORTREVISION?= 1
CATEGORIES+= textproc
MASTER_SITES= http://fmg-www.cs.ucla.edu/geoff/tars/
DISTNAME= ispell-3.2.06 # needed for slave ports / options
diff --git a/textproc/ispell/files/patch-ac b/textproc/ispell/files/patch-ac
new file mode 100644
index 000000000000..565b6556e7ca
--- /dev/null
+++ b/textproc/ispell/files/patch-ac
@@ -0,0 +1,12 @@
+--- correct.c.orig Wed Jul 25 23:51:47 2001
++++ correct.c Thu Feb 21 21:15:51 2002
+@@ -1600,7 +1600,9 @@
+ ch = getc (stdin);
+ if (ch == EOF)
+ break;
++ contextbufs[0][bufsize] = (char) ch;
+ filteredbuf[bufsize++] = (char) ch;
++ contextbufs[0][bufsize] = '\0';
+ filteredbuf[bufsize] = '\0';
+ }
+ }