aboutsummaryrefslogtreecommitdiff
path: root/textproc/jing
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2002-02-09 09:30:35 +0000
committerKevin Lo <kevlo@FreeBSD.org>2002-02-09 09:30:35 +0000
commit61c0eaedc03cae6bf29ca8ed163076a383c503ca (patch)
tree9da0f5fa06cf8b2554700d95a748e9e56a58711f /textproc/jing
parenta19d8120e2c5cfa3b72e1e8493c4f67190e2ba5e (diff)
downloadports-61c0eaedc03cae6bf29ca8ed163076a383c503ca.tar.gz
ports-61c0eaedc03cae6bf29ca8ed163076a383c503ca.zip
Notes
Diffstat (limited to 'textproc/jing')
-rw-r--r--textproc/jing/Makefile43
-rw-r--r--textproc/jing/distinfo3
-rw-r--r--textproc/jing/pkg-comment1
-rw-r--r--textproc/jing/pkg-descr8
-rw-r--r--textproc/jing/pkg-plist4
5 files changed, 59 insertions, 0 deletions
diff --git a/textproc/jing/Makefile b/textproc/jing/Makefile
new file mode 100644
index 000000000000..2b8385673a9f
--- /dev/null
+++ b/textproc/jing/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: jing
+# Date created: 3 February 2002
+# Whom: Kimura Fuyuki <fuyuki@mj.0038.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jing
+PORTVERSION= 2001.12.03
+CATEGORIES= textproc
+MASTER_SITES= http://www.thaiopensource.com/relaxng/
+DISTNAME= ${PORTNAME}
+DISTFILES= ${JAR} jing.html copying.txt
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY=
+
+MAINTAINER= fuyuki@mj.0038.net
+
+JAXP?= crimson # or xalan, saxon
+
+RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
+
+.if ${JAXP} == "xalan"
+RUN_DEPENDS+= ${LOCALBASE}/xalan-j2.1.0/bin/${JAXP}.jar:${PORTSDIR}/java/xalan-j
+.else
+RUN_DEPENDS+= ${LOCALBASE}/share/java/classes/${JAXP}.jar:${PORTSDIR}/textproc/${JAXP}
+.endif
+
+NO_BUILD= yes
+
+JAR= ${DISTNAME}.jar
+JAVALIBDIR= ${PREFIX}/share/java/classes
+
+do-install:
+ ${MKDIR} ${JAVALIBDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${JAR} ${JAVALIBDIR}
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/*.txt ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/jing/distinfo b/textproc/jing/distinfo
new file mode 100644
index 000000000000..eb2861b177a7
--- /dev/null
+++ b/textproc/jing/distinfo
@@ -0,0 +1,3 @@
+MD5 (jing/jing.jar) = 3b52144b5620c1fb8060f41eda6820d4
+MD5 (jing/jing.html) = dea9404501c85548caeba430065eb3c5
+MD5 (jing/copying.txt) = febb9f1c62da7a0b7838728442c2d44f
diff --git a/textproc/jing/pkg-comment b/textproc/jing/pkg-comment
new file mode 100644
index 000000000000..20bad05ccd10
--- /dev/null
+++ b/textproc/jing/pkg-comment
@@ -0,0 +1 @@
+A RELAX NG validator in Java
diff --git a/textproc/jing/pkg-descr b/textproc/jing/pkg-descr
new file mode 100644
index 000000000000..fd7245051c48
--- /dev/null
+++ b/textproc/jing/pkg-descr
@@ -0,0 +1,8 @@
+Jing is a validator for RELAX NG implemented in Java. It uses a
+vendor-independent Java interface for RELAX NG datatype libraries and
+can use any datatype library that implements this interface.
+
+WWW: http://www.thaiopensource.com/relaxng/jing.html
+
+- Kimura Fuyuki
+fuyuki@mj.0038.net
diff --git a/textproc/jing/pkg-plist b/textproc/jing/pkg-plist
new file mode 100644
index 000000000000..fa7306fcc8d7
--- /dev/null
+++ b/textproc/jing/pkg-plist
@@ -0,0 +1,4 @@
+share/java/classes/jing.jar
+share/doc/jing/copying.txt
+share/doc/jing/jing.html
+@dirrm share/doc/jing