aboutsummaryrefslogtreecommitdiff
path: root/textproc/jrefentry
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2002-02-07 01:32:48 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2002-02-07 01:32:48 +0000
commit2709f34636da81161f4373adfdafea768ffb5f3f (patch)
tree04753c0f223b0d05ff5eccce68073a14cd32169f /textproc/jrefentry
parente8ebeab9d2dd15b92969cd4341a9a40c14847ad1 (diff)
downloadports-2709f34636da81161f4373adfdafea768ffb5f3f.tar.gz
ports-2709f34636da81161f4373adfdafea768ffb5f3f.zip
Notes
Diffstat (limited to 'textproc/jrefentry')
-rw-r--r--textproc/jrefentry/Makefile40
-rw-r--r--textproc/jrefentry/distinfo1
-rw-r--r--textproc/jrefentry/pkg-comment1
-rw-r--r--textproc/jrefentry/pkg-descr8
-rw-r--r--textproc/jrefentry/pkg-plist9
5 files changed, 59 insertions, 0 deletions
diff --git a/textproc/jrefentry/Makefile b/textproc/jrefentry/Makefile
new file mode 100644
index 000000000000..e12e24227b3e
--- /dev/null
+++ b/textproc/jrefentry/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: jrefentry
+# Date created: 1 February 2002
+# Whom: Kimura Fuyuki <fuyuki@mj.0038.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= jrefentry
+PORTVERSION= 1.1
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= docbook
+
+MAINTAINER= fuyuki@mj.0038.net
+
+RUN_DEPENDS= ${LOCALBASE}/share/xml/docbook/catalog:${PORTSDIR}/textproc/docbook-xml \
+ ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
+
+NO_BUILD= yes
+PLIST_SUB= MKCATALOG=${MKCATALOG} CATALOG=${CATALOG}
+
+XMLDIR= ${PREFIX}/share/xml/docbook/${PORTNAME}
+
+MKCATALOG= ${LOCALBASE}/sbin/mkcatalog
+CATALOG= ${PREFIX}/share/xml/docbook/catalog
+
+do-install:
+ ${MKDIR} ${XMLDIR}
+ ${INSTALL_DATA} ${WRKSRC}/jrefentry.dtd ${XMLDIR}
+ ${ECHO_CMD} 'PUBLIC "-//Norman Walsh//DTD JRefEntry V1.1//EN" "jrefentry.dtd"' \
+ >${XMLDIR}/catalog
+
+post-install:
+ ${MKCATALOG} -c ${CATALOG} -q install jrefentry
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/jtest.xml ${EXAMPLESDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/textproc/jrefentry/distinfo b/textproc/jrefentry/distinfo
new file mode 100644
index 000000000000..9baed21b1094
--- /dev/null
+++ b/textproc/jrefentry/distinfo
@@ -0,0 +1 @@
+MD5 (jrefentry-1.1.tar.gz) = 6e1bb5ce62443ce32b3302b1a97b9441
diff --git a/textproc/jrefentry/pkg-comment b/textproc/jrefentry/pkg-comment
new file mode 100644
index 000000000000..59776240b7fc
--- /dev/null
+++ b/textproc/jrefentry/pkg-comment
@@ -0,0 +1 @@
+DocBook XML JRefEntry DTD
diff --git a/textproc/jrefentry/pkg-descr b/textproc/jrefentry/pkg-descr
new file mode 100644
index 000000000000..ff0d68c0cda4
--- /dev/null
+++ b/textproc/jrefentry/pkg-descr
@@ -0,0 +1,8 @@
+The JRefEntry DTD is a customization of the DocBook RefEntry
+model. The purpose of this customization is to mirror the order and
+nature of structured comment tags in JavaDoc documentation.
+
+WWW: http://docbook.sourceforge.net/projects/jrefentry/
+
+- Kimura Fuyuki
+fuyuki@mj.0038.net
diff --git a/textproc/jrefentry/pkg-plist b/textproc/jrefentry/pkg-plist
new file mode 100644
index 000000000000..857db0b22533
--- /dev/null
+++ b/textproc/jrefentry/pkg-plist
@@ -0,0 +1,9 @@
+@unexec %%MKCATALOG%% -c %%CATALOG%% -q deinstall jrefentry
+share/xml/docbook/jrefentry/catalog
+@exec %%MKCATALOG%% -c %%CATALOG%% -q install jrefentry
+share/xml/docbook/jrefentry/jrefentry.dtd
+@dirrm share/xml/docbook/jrefentry
+share/examples/jrefentry/jtest.xml
+@dirrm share/examples/jrefentry
+share/doc/jrefentry/README.html
+@dirrm share/doc/jrefentry