aboutsummaryrefslogtreecommitdiff
path: root/textproc/kbedic
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2003-12-14 11:14:16 +0000
committerPeter Pentchev <roam@FreeBSD.org>2003-12-14 11:14:16 +0000
commit513710847e6b01a5c4062b2aaa2e590ee0d9f36d (patch)
treee3521f4fdf8a584efc8198c7bc41eb7bb3535e4f /textproc/kbedic
parent6328a8a5ce97905619b639946a9c7b907a8738f5 (diff)
downloadports-513710847e6b01a5c4062b2aaa2e590ee0d9f36d.tar.gz
ports-513710847e6b01a5c4062b2aaa2e590ee0d9f36d.zip
Notes
Diffstat (limited to 'textproc/kbedic')
-rw-r--r--textproc/kbedic/Makefile6
-rw-r--r--textproc/kbedic/files/patch-src::database.cpp11
-rw-r--r--textproc/kbedic/files/patch-src::registry.cpp29
-rw-r--r--textproc/kbedic/files/patch-src::translator.cpp38
-rw-r--r--textproc/kbedic/files/src::cbedic.cpp.patch16
-rw-r--r--textproc/kbedic/files/src::win.cpp.patch11
6 files changed, 107 insertions, 4 deletions
diff --git a/textproc/kbedic/Makefile b/textproc/kbedic/Makefile
index de35b2183f95..24a205842dd8 100644
--- a/textproc/kbedic/Makefile
+++ b/textproc/kbedic/Makefile
@@ -29,16 +29,14 @@ CONFIGURE_ARGS= --datadir=${DICT_DIR}
USE_QT_VER= 2
USE_X_PREFIX= yes
CONFIGURE_ARGS+= --with-x
+EXTRA_PATCHES+= ${FILESDIR}/src::win.cpp.patch
.else
PLIST= ${PKGDIR}/pkg-plist.console
+EXTRA_PATCHES+= ${FILESDIR}/src::cbedic.cpp.patch
.endif
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 500113
-BROKEN= "Does not compile"
-.endif
-
pre-fetch:
@${ECHO_MSG} " --- Dictionaries setup information ---"
@${ECHO_MSG} "This port uses dictionaries provided by the textproc/bedic-data port."
diff --git a/textproc/kbedic/files/patch-src::database.cpp b/textproc/kbedic/files/patch-src::database.cpp
new file mode 100644
index 000000000000..1d6d37a0ee42
--- /dev/null
+++ b/textproc/kbedic/files/patch-src::database.cpp
@@ -0,0 +1,11 @@
+--- src/database.cpp.old Fri Dec 12 03:18:26 2003
++++ src/database.cpp Fri Dec 12 03:18:39 2003
+@@ -106,7 +106,7 @@
+ // Open data file and set some variables
+ // Return true if success, false if failed
+ //========================================================================
+-bool Database::createDictionary(const char *fileName, const long fixedLastWordPointer = 0) {
++bool Database::createDictionary(const char *fileName, const long fixedLastWordPointer) {
+ // Ensure against invoking twice
+ if (dataFile != NULL) {
+ return false;
diff --git a/textproc/kbedic/files/patch-src::registry.cpp b/textproc/kbedic/files/patch-src::registry.cpp
new file mode 100644
index 000000000000..90bf0355071e
--- /dev/null
+++ b/textproc/kbedic/files/patch-src::registry.cpp
@@ -0,0 +1,29 @@
+--- src/registry.cpp.old Fri Dec 12 03:16:27 2003
++++ src/registry.cpp Fri Dec 12 03:16:48 2003
+@@ -79,7 +79,7 @@
+ //=== Get String =========================================================
+ // Return the value of key, if missed return default value
+ //========================================================================
+-char *Registry::getString(const char *property, const char *defaultValue = "") {
++char *Registry::getString(const char *property, const char *defaultValue) {
+ bool found = false;
+ char *ret = NULL;
+ FILE *f;
+@@ -113,7 +113,7 @@
+ //=== Get Int ============================================================
+ // Return the value of key, if missed return default value
+ //========================================================================
+-int Registry::getInt(const char *property, const int defaultValue = 0) {
++int Registry::getInt(const char *property, const int defaultValue) {
+ int ret = defaultValue;
+ char *p;
+ p = getString(property);
+@@ -141,7 +141,7 @@
+ //=== Get Bool ===========================================================
+ // Return the value of key, if missed return default value
+ //========================================================================
+-bool Registry::getBool(const char *property, const bool defaultValue = false) {
++bool Registry::getBool(const char *property, const bool defaultValue) {
+ bool ret = defaultValue;
+ char *p;
+ p = getString(property);
diff --git a/textproc/kbedic/files/patch-src::translator.cpp b/textproc/kbedic/files/patch-src::translator.cpp
new file mode 100644
index 000000000000..5ed989d6f008
--- /dev/null
+++ b/textproc/kbedic/files/patch-src::translator.cpp
@@ -0,0 +1,38 @@
+--- src/translator.cpp.old Fri Dec 12 03:19:37 2003
++++ src/translator.cpp Fri Dec 12 03:20:30 2003
+@@ -119,7 +119,7 @@
+ // Real construcor
+ // Call the same method of Database, and return same result
+ //========================================================================
+-bool Translator::createDictionary(const char *fileName, const int dictionary, const long fixedLastWordPointer = 0) {
++bool Translator::createDictionary(const char *fileName, const int dictionary, const long fixedLastWordPointer) {
+ bool ret = false;
+ switch (dictionary) {
+ case ENG_BUL:
+@@ -275,7 +275,7 @@
+ // Return true if passed word is legal bulgarian word as LATIN_INPUT
+ // Return pointer to new word that is legal dictionary word
+ //========================================================================
+-bool Translator::isLatinInput(const char *word, char *buf, const bool ignoreSpace = false) {
++bool Translator::isLatinInput(const char *word, char *buf, const bool ignoreSpace) {
+ int i = 0;
+ char *p;
+ while (word[i] != '\0') {
+@@ -304,7 +304,7 @@
+ // to a normal latin output
+ // Change buffer and return pointer to new word
+ //========================================================================
+-char *Translator::toLatin(const char *word, char *buf, const bool legalLatinInput = true) {
++char *Translator::toLatin(const char *word, char *buf, const bool legalLatinInput) {
+ int i = 0;
+ int j = 0;
+ char *p;
+@@ -348,7 +348,7 @@
+ // Call the same method of Database, and return same result
+ // But perform some operations
+ //========================================================================
+-char *Translator::getWord(const bool lowerCase = true, const bool legalLatinInput = true) {
++char *Translator::getWord(const bool lowerCase, const bool legalLatinInput) {
+ char *ret = NULL;
+ switch (currentDictionary) {
+ case ENG_BUL:
diff --git a/textproc/kbedic/files/src::cbedic.cpp.patch b/textproc/kbedic/files/src::cbedic.cpp.patch
new file mode 100644
index 000000000000..1d7fcab02e72
--- /dev/null
+++ b/textproc/kbedic/files/src::cbedic.cpp.patch
@@ -0,0 +1,16 @@
+--- src/cbedic.cpp.old Fri Dec 12 04:51:13 2003
++++ src/cbedic.cpp Fri Dec 12 04:51:35 2003
+@@ -24,10 +24,12 @@
+ **********************************************************************/
+
+
+-#include <iostream.h>
++#include <iostream>
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <string.h>
++
++using namespace std;
+
+ #include "defaults.h"
+ #include "translator.h"
diff --git a/textproc/kbedic/files/src::win.cpp.patch b/textproc/kbedic/files/src::win.cpp.patch
new file mode 100644
index 000000000000..805a8c5fcbdd
--- /dev/null
+++ b/textproc/kbedic/files/src::win.cpp.patch
@@ -0,0 +1,11 @@
+--- src/win.cpp.old Fri Dec 12 04:29:29 2003
++++ src/win.cpp Fri Dec 12 04:29:38 2003
+@@ -218,7 +218,7 @@
+ // Create GUI
+ // Init objects and set default variables
+ //========================================================================
+-Win::Win(QWidget *parent = 0, const char *name = 0):QMainWindow(parent, name) {
++Win::Win(QWidget *parent, const char *name):QMainWindow(parent, name) {
+
+ // Init some variables
+ fromSystemHighlighted = false;