aboutsummaryrefslogtreecommitdiff
path: root/textproc/kdiff3/Makefile
diff options
context:
space:
mode:
authorMarkus Brueffer <markus@FreeBSD.org>2004-06-07 14:28:45 +0000
committerMarkus Brueffer <markus@FreeBSD.org>2004-06-07 14:28:45 +0000
commit55f0138e434a296d630f669f3b786f4e18d6347b (patch)
treee5f6658fb006ccf00a24d30430b110c96fbd7d29 /textproc/kdiff3/Makefile
parent6d6aedda5db5584d625ae4ed268d66465a06aeb5 (diff)
Notes
Diffstat (limited to 'textproc/kdiff3/Makefile')
-rw-r--r--textproc/kdiff3/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/textproc/kdiff3/Makefile b/textproc/kdiff3/Makefile
index e99ce95800a3..d45292634590 100644
--- a/textproc/kdiff3/Makefile
+++ b/textproc/kdiff3/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= kdiff3
-PORTVERSION= 0.9.83
-PORTREVISION= 1
+PORTVERSION= 0.9.84
CATEGORIES= textproc kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,11 +14,12 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= h.eichmann@gmx.de
COMMENT= A KDE3 graphical frontend for diff
-CONFIGURE_ARGS+= --program-transform-name=s,^,,
-
USE_KDELIBS_VER= 3
GNU_CONFIGURE= yes
USE_LIBTOOL_VER= 13
+USE_REINPLACE= yes
+
+CONFIGURE_ENV= LDFLAGS="${PTHREAD_LIBS}"
MAN1= kdiff3.1
@@ -28,6 +28,8 @@ pre-configure:
${TOUCH} ${WRKSRC}/${i}
.endfor
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2 ||g; s|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>