aboutsummaryrefslogtreecommitdiff
path: root/textproc/kiss-templates
diff options
context:
space:
mode:
authorMichael Gmelin <grembo@FreeBSD.org>2017-02-28 23:28:55 +0000
committerMichael Gmelin <grembo@FreeBSD.org>2017-02-28 23:28:55 +0000
commitf7619b089952a1d6a3e0287b044050ba954185c3 (patch)
tree1103d72f57a2f0a1849fe987c27cdb448a34a7f4 /textproc/kiss-templates
parent219539d204b1bfc6d15ac1db38ef682e05c52eaa (diff)
downloadports-f7619b089952a1d6a3e0287b044050ba954185c3.tar.gz
ports-f7619b089952a1d6a3e0287b044050ba954185c3.zip
Notes
Diffstat (limited to 'textproc/kiss-templates')
-rw-r--r--textproc/kiss-templates/Makefile32
-rw-r--r--textproc/kiss-templates/distinfo3
-rw-r--r--textproc/kiss-templates/pkg-descr3
3 files changed, 38 insertions, 0 deletions
diff --git a/textproc/kiss-templates/Makefile b/textproc/kiss-templates/Makefile
new file mode 100644
index 000000000000..64033bcdd844
--- /dev/null
+++ b/textproc/kiss-templates/Makefile
@@ -0,0 +1,32 @@
+# Created by: Andreas Sommer <andreas.sommer87@googlemail.com>
+# $FreeBSD$
+
+PORTNAME= kiss-templates
+PORTVERSION= 0.18
+CATEGORIES= textproc
+
+MAINTAINER= andreas.sommer87@googlemail.com
+COMMENT= Type safe "Keep it simple, stupid" text templates for C++
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= rbock
+
+PLIST_FILES= bin/kiste2cpp \
+ include/kiste/html.h \
+ include/kiste/kiste.h \
+ include/kiste/raw.h \
+ include/kiste/terminal.h
+
+USES= cmake
+
+OPTIONS_DEFINE= TEST
+TEST_DESC= Build with unit tests
+TEST_BUILD_DEPENDS= boost-libs>=1.55:devel/boost-libs
+TEST_USES= python:2,build,test shebangfix
+TEST_TEST_TARGET= test
+SHEBANG_FILES= tests/comparison-based/generate.py tests/differ.py
+
+.include <bsd.port.mk>
diff --git a/textproc/kiss-templates/distinfo b/textproc/kiss-templates/distinfo
new file mode 100644
index 000000000000..58dd59ec0bbc
--- /dev/null
+++ b/textproc/kiss-templates/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488320042
+SHA256 (rbock-kiss-templates-0.18_GH0.tar.gz) = 9ef6441b6dff992de8a8189b35293bef2b8f1892dee2f3d1dd6d0d6d6f6fb5e9
+SIZE (rbock-kiss-templates-0.18_GH0.tar.gz) = 27930
diff --git a/textproc/kiss-templates/pkg-descr b/textproc/kiss-templates/pkg-descr
new file mode 100644
index 000000000000..7da4a6f5ec79
--- /dev/null
+++ b/textproc/kiss-templates/pkg-descr
@@ -0,0 +1,3 @@
+Type safe "Keep it simple, stupid" text templates for C++.
+
+WWW: https://github.com/rbock/kiss-templates