aboutsummaryrefslogtreecommitdiff
path: root/textproc/kmfl-sil-galatia
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-09-02 17:26:54 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-09-02 17:26:54 +0000
commitfcb480eff1c57edb03e11b9e303b6292a2a6c591 (patch)
tree4e9b8c30e630bf82d2bfffa7ff795fe4c14bcecc /textproc/kmfl-sil-galatia
parentdf43c95b1e835d536af57b38fbf7f906ae947b5b (diff)
downloadports-fcb480eff1c57edb03e11b9e303b6292a2a6c591.tar.gz
ports-fcb480eff1c57edb03e11b9e303b6292a2a6c591.zip
Notes
Diffstat (limited to 'textproc/kmfl-sil-galatia')
-rw-r--r--textproc/kmfl-sil-galatia/Makefile62
-rw-r--r--textproc/kmfl-sil-galatia/distinfo3
-rw-r--r--textproc/kmfl-sil-galatia/files/patch-GrkPolyComp.KMN37
-rw-r--r--textproc/kmfl-sil-galatia/pkg-descr15
4 files changed, 117 insertions, 0 deletions
diff --git a/textproc/kmfl-sil-galatia/Makefile b/textproc/kmfl-sil-galatia/Makefile
new file mode 100644
index 000000000000..eb555c3aa488
--- /dev/null
+++ b/textproc/kmfl-sil-galatia/Makefile
@@ -0,0 +1,62 @@
+# New ports collection makefile for: scim-kmfl-sil-galatia
+# Date created: 24 August 2009
+# Whom: Nikola Lecic <nikola.lecic@anthesphoria.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= scim-kmfl-sil-galatia
+PORTVERSION= 1.02
+CATEGORIES= textproc
+MASTER_SITES= http://scripts.sil.org/cms/scripts/render_download.php?site_id=nrsi&format=file&media_id=GrkPolyComp_Src&filename=/ \
+ http://anthesphoria.net/FreeBSD/ports/distfiles/${DIST_SUBDIR}/
+DISTNAME= GrkPolyComp_Src
+DIST_SUBDIR= kmfl
+
+MAINTAINER= nikola.lecic@anthesphoria.net
+COMMENT= SCIM KMFL IMEngine Unicode keyboard for typesetting Ancient Greek
+
+RUN_DEPENDS= kmflcomp:${PORTSDIR}/textproc/kmflcomp \
+ ${LOCALBASE}/lib/scim-1.0/1.4.0/IMEngine/kmfl.so:${PORTSDIR}/textproc/scim-kmfl-imengine
+
+WRKSRC= ${WRKDIR}/GrkPolyComp_Src
+USE_DOS2UNIX= GrkPolyComp.KMN
+NO_BUILD= yes
+USE_ZIP= yes
+
+DOCSDIR_REL= share/doc/kmfl/${PORTNAME}
+DOCSDIR= ${PREFIX}/${DOCSDIR_REL}
+SCIM_KMFL_DIR= share/scim/kmfl
+SCIM_KMFL_ICONS_DIR= share/scim/kmfl/icons
+
+PORTDOCS= *
+DOCSLIST= Greek\ Poly\ Comp\ Kbrd\ Layout.pdf \
+ welcome.htm
+
+PLIST_FILES= ${SCIM_KMFL_DIR}/GrkPolyComp.kmn \
+ ${SCIM_KMFL_ICONS_DIR}/ALPHA.bmp
+
+do-install:
+ ${CP} -f ${WRKSRC}/GrkPolyComp.KMN ${WRKSRC}/GrkPolyComp.kmn
+ ${INSTALL_DATA} ${WRKSRC}/GrkPolyComp.kmn ${LOCALBASE}/${SCIM_KMFL_DIR}
+ ${INSTALL_DATA} ${WRKSRC}/ALPHA.bmp ${LOCALBASE}/${SCIM_KMFL_ICONS_DIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ for doc in ${DOCSLIST} ; do \
+ ${INSTALL_DATA} "${WRKSRC}/$$doc" ${DOCSDIR} ; \
+ done
+.endif
+
+post-install:
+ @${ECHO_MSG} "--------------------------------------------------------"
+ @${ECHO_MSG} " You should now have the new keyboard in the section"
+ @${ECHO_MSG} " \"Others\" in your SCIM menu. If you don't see it,"
+ @${ECHO_MSG} " restart X."
+.if !defined(NOPORTDOCS)
+ @${ECHO_MSG}
+ @${ECHO_MSG} " The documentation is installed into:"
+ @${ECHO_MSG} " ${DOCSDIR}"
+.endif
+ @${ECHO_MSG} "--------------------------------------------------------"
+
+.include <bsd.port.mk>
diff --git a/textproc/kmfl-sil-galatia/distinfo b/textproc/kmfl-sil-galatia/distinfo
new file mode 100644
index 000000000000..8caab4fd023e
--- /dev/null
+++ b/textproc/kmfl-sil-galatia/distinfo
@@ -0,0 +1,3 @@
+MD5 (kmfl/GrkPolyComp_Src.zip) = 5e7bf6186a3917d796f1abb710bed539
+SHA256 (kmfl/GrkPolyComp_Src.zip) = 59b4ad7f7a31f66a674f1867979baf07ae5143957cec6575e3d1428f5acf66e7
+SIZE (kmfl/GrkPolyComp_Src.zip) = 197829
diff --git a/textproc/kmfl-sil-galatia/files/patch-GrkPolyComp.KMN b/textproc/kmfl-sil-galatia/files/patch-GrkPolyComp.KMN
new file mode 100644
index 000000000000..9804d2bc16be
--- /dev/null
+++ b/textproc/kmfl-sil-galatia/files/patch-GrkPolyComp.KMN
@@ -0,0 +1,37 @@
+--- GrkPolyComp.KMN.orig 2009-08-24 13:49:16.000000000 +0200
++++ GrkPolyComp.KMN 2009-08-24 14:03:17.000000000 +0200
+@@ -24,9 +24,9 @@
+ c See REVISION.TXT
+ c ----------------------------------------------------------------------------
+
+-NAME "Greek (polytonic precomposed) Unicode 1.02"
++NAME "Galatia Greek (polytonic precomposed) Unicode 1.02"
+ VERSION 6.0
+-BITMAP ALPHA
++BITMAP ALPHA.bmp
+ HOTKEY "^+G"
+ COPYRIGHT "© 2002-2008 SIL International"
+ MESSAGE "The Greek (polytonic precomposed) Unicode keyboard is distributed under the X11 free software license (http://scripts.sil.org/X11License)."
+@@ -520,9 +520,9 @@
+ any(vUIoSm0) + any(K_Io) > index(vUIoSm,1) c >A_
+ any(vUIo2) + any(K_Ro) > index(vUIoRo,1) c A_<
+ any(vUIoRo0) + any(K_Io) > index(vUIoRo,1) c <A_
+-any(vUIoSm) + any(K_Gr) > index(vUIoSmGr,1) c A_>\
++any(vUIoSm) + any(K_Gr) > index(vUIoSmGr,1) c A_>\ c
+ any(vUIoSmGr0) + any(K_Io) > index(vUIoSmGr,1) c >\A_
+-any(vUIoRo) + any(K_Gr) > index(vUIoRoGr,1) c A_<\
++any(vUIoRo) + any(K_Gr) > index(vUIoRoGr,1) c A_<\ c
+ any(vUIoRoGr0) + any(K_Io) > index(vUIoRoGr,1) c <\A_
+ any(vUIoSm) + any(K_Ac) > index(vUIoSmAc,1) c A_>/
+ any(vUIoSmAc0) + any(K_Io) > index(vUIoSmAc,1) c >/A_
+@@ -668,8 +668,8 @@
+ any(GC_Ci) + any(K_Gr) > index(GC_Gr,1) c a^ + \ a\.
+ any(Ac) + any(K_Gr) > outs(Gr) c / + \ \.
+ any(Ci) + any(K_Gr) > outs(Gr) c ^ + \ \.
+-any(lowvRo) + any(K_Gr) > index(lowvRoGr,1) c >a + \ a>\
+-any(lowvSm) + any(K_Gr) > index(lowvSmGr,1) c <a + \ a<\
++any(lowvRo) + any(K_Gr) > index(lowvRoGr,1) c >a + \ a>\ c
++any(lowvSm) + any(K_Gr) > index(lowvSmGr,1) c <a + \ a<\ c
+ any(upV) + any(K_Gr) > index(upVGr,1) c A + \ >A
+ any(upVSm_Sm) + any(K_Gr) > index(upVSmGr,1) c >A + \ >\A
+ any(upVSm_Gr) + any(K_Sm) > index(upVSmGr,1) c >A + \ >\A
diff --git a/textproc/kmfl-sil-galatia/pkg-descr b/textproc/kmfl-sil-galatia/pkg-descr
new file mode 100644
index 000000000000..d110dfb2d483
--- /dev/null
+++ b/textproc/kmfl-sil-galatia/pkg-descr
@@ -0,0 +1,15 @@
+This is a keyboard for typesetting Ancient Greek with precomposed Unicode
+characters. It is written in Keyman Keyboard Language by SIL Non-Roman Script
+Initiative (NRSI).
+
+The main purpose of the keyboards is to provide a wide range of keying options,
+so many characters can be entered in multiple ways. The features include:
+
+ * preserving the context when deleting;
+ * choosing the correct code for the sigma depending upon the encoding and
+ the context (so the correct final form is used when appropriate);
+ * understanding the context of gamma so that it can be typed as 'n' before
+ kappa, xi or chi and as 'ng' before another gamma.
+ * support for Greek punctuation.
+
+WWW: http://scripts.sil.org/KeymanKeyboardLinks#e9f80714