aboutsummaryrefslogtreecommitdiff
path: root/textproc/latex2html/Makefile
diff options
context:
space:
mode:
authorPeter Pentchev <roam@FreeBSD.org>2000-12-11 16:44:46 +0000
committerPeter Pentchev <roam@FreeBSD.org>2000-12-11 16:44:46 +0000
commitcb91768d8b7c2f9cd17180e82e04f2dc9821b68e (patch)
tree80082c2d300c43ca23406623c0711f45259cbd3e /textproc/latex2html/Makefile
parent567f39d5ecdedae9ed3a69d0a20f591df994b533 (diff)
downloadports-cb91768d8b7c2f9cd17180e82e04f2dc9821b68e.tar.gz
ports-cb91768d8b7c2f9cd17180e82e04f2dc9821b68e.zip
Notes
Diffstat (limited to 'textproc/latex2html/Makefile')
-rw-r--r--textproc/latex2html/Makefile71
1 files changed, 16 insertions, 55 deletions
diff --git a/textproc/latex2html/Makefile b/textproc/latex2html/Makefile
index 5e057f5a51e4..8cede1bed39d 100644
--- a/textproc/latex2html/Makefile
+++ b/textproc/latex2html/Makefile
@@ -6,70 +6,31 @@
#
PORTNAME= latex2html
-PORTVERSION= 98.1p1
+PORTVERSION= 99.2b8
CATEGORIES= textproc
-MASTER_SITES= http://www-dsed.llnl.gov/files/programs/unix/latex2html/sources/ \
- ftp://ftp.mpn.com/pub/nikos/latex2html-mirror/sources/
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= support/${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/b/beta/}
MAINTAINER= brett@peloton.runet.edu
-RUN_DEPENDS= ${LOCALBASE}/bin/latex:${PORTSDIR}/print/latex \
- ${LOCALBASE}/bin/dvips:${PORTSDIR}/print/dvips \
+BUILD_DEPENDS= ${LOCALBASE}/bin/latex:${PORTSDIR}/print/teTeX \
${LOCALBASE}/bin/gs:${PORTSDIR}/print/ghostscript55 \
${LOCALBASE}/bin/anytopnm:${PORTSDIR}/graphics/netpbm
-
-WRKSRC= ${WRKDIR}/latex2html
+RUN_DEPENDS= ${BUILD_DEPENDS}
USE_PERL5= yes
-NO_BUILD= yes
-IS_INTERACTIVE= yes
-NO_PACKAGE= An interrogation follows installation
-
-post-patch:
- @${PERL} -pi -e 's:/usr/local/bin/perl:${PERL}:' ${WRKSRC}/latex2html
- @${PERL} -pi -e 's:/usr/local/bin/perl:${PERL}:' ${WRKSRC}/configure-pstoimg
- @${PERL} -pi -e 's:/usr/local/bin/perl:${PERL}:' ${WRKSRC}/install-test
- @${PERL} -pi -e 's:/usr/local/bin/perl:${PERL}:' ${WRKSRC}/makemap
- @${PERL} -pi -e 's:/usr/local/bin/perl:${PERL}:' ${WRKSRC}/pstoimg
- @${PERL} -pi -e 's:/usr/local/bin/perl:${PERL}:' ${WRKSRC}/pstoimg_nopipes
- @${PERL} -pi -e 's:/usr/local/bin/perl:${PERL}:' ${WRKSRC}/texexpand
-
-do-install:
- @${MKDIR} ${PREFIX}/share/latex2html
- @${INSTALL_DATA} ${FILESDIR}/local.pm ${PREFIX}/share/latex2html
- @ for dir in makeseg IndicTeX-HTML cweb2html docs example icons.gif icons.png styles tests versions; do \
- ${CP} -R ${WRKSRC}/$$dir ${PREFIX}/share/latex2html; \
- done
- @ for prog in Override.pm configure-pstoimg install-test latex2html makemap pstoimg\
- pstoimg_nopipes texexpand; do \
- ${INSTALL_SCRIPT} ${WRKSRC}/$$prog ${PREFIX}/share/latex2html; \
- done
- @ for file in FAQ MANIFEST README README.dvips dot.latex2html-init latex2html.config ; do \
- ${INSTALL_DATA} ${WRKSRC}/$$file ${PREFIX}/share/latex2html; \
- done
- @${MKDIR} ${PREFIX}/share/texmf/tex/latex/latex2html
- @${INSTALL_DATA} ${WRKSRC}/texinputs/* ${PREFIX}/share/texmf/tex/latex/latex2html
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-perl=${PERL} \
+ --libdir=${PREFIX}/share/${PORTNAME}
post-install:
- @cd ${PREFIX}/share/latex2html && ${SETENV} LATEX2HTMLDIR=${PREFIX}/share/latex2html ${PERL5} ${PREFIX}/share/latex2html/install-test
- @${INSTALL_SCRIPT} ${PREFIX}/share/latex2html/latex2html ${PREFIX}/bin
- @${ECHO_MSG} "********************************************************"
- @${ECHO_MSG} "Latex2html has now been installed with a very basic"
- @${ECHO_MSG} "configuration and HTML specific style files have been"
- @${ECHO_MSG} "moved to ${PREFIX}/share/texmf/tex/latex/latex2html."
- @${ECHO_MSG} "You will need to make sure that latex can now see these"
- @${ECHO_MSG} "style files, for instance by running texhash if you are"
- @${ECHO_MSG} "using teTeX. Due to the differences in how web "
- @${ECHO_MSG} "servers are set up, it's probably a good idea to read"
- @${ECHO_MSG} "through the configuration, which can be found in "
- @${ECHO_MSG} "${PREFIX}/local/share/latex2html/latex2html.config"
- @${ECHO_MSG} "and adjusting things to set up system wide preferences."
- @${ECHO_MSG} "You may then want to re-run install-test found in the"
- @${ECHO_MSG} "same directory and copy the new latex2html script"
- @${ECHO_MSG} "to ${PREFIX}/local/bin. Individual user configurations"
- @${ECHO_MSG} "can be accomplished by placing a copy of"
- @${ECHO_MSG} "${PREFIX}/local/share/latex2html/dot.latex2html-init"
- @${ECHO_MSG} "in the user's home directory and editing to preference."
- @${ECHO_MSG} "********************************************************"
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+.for file in FAQ INSTALL LICENSE README
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/${PORTNAME}
+.endfor
+.endif
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>