aboutsummaryrefslogtreecommitdiff
path: root/textproc/libcrm114/Makefile
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-11-22 18:08:28 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-11-22 18:08:28 +0000
commit3430919bbf34a9fcae61243b9fc1d0569a5d528d (patch)
treecaef35be351f35533e4ca277418d571bad0e2dbb /textproc/libcrm114/Makefile
parent352e4dd6cc5c28ceb8dfc542493c55a0bd65710b (diff)
Notes
Diffstat (limited to 'textproc/libcrm114/Makefile')
-rw-r--r--textproc/libcrm114/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/textproc/libcrm114/Makefile b/textproc/libcrm114/Makefile
new file mode 100644
index 000000000000..862a224b06b6
--- /dev/null
+++ b/textproc/libcrm114/Makefile
@@ -0,0 +1,35 @@
+# Created: Martin Schuette <info@mschuette.name>
+# $FreeBSD$
+
+PORTNAME= libcrm114
+PORTVERSION= 20100726
+CATEGORIES= textproc
+MASTER_SITES= http://crm114.sourceforge.net/tarballs/
+
+MAINTAINER= info@mschuette.name
+COMMENT= CRM114 C-callable Library
+
+LIB_DEPENDS= tre:${PORTSDIR}/textproc/libtre
+
+LICENCE= LGPL3
+
+USE_GMAKE= yes
+USE_LDCONFIG= yes
+
+# pass stuff to gmake
+CFLAGS+= -I${LOCALBASE}/include
+CFLAGS+= -DNO_LOGL -DDO_INLINES
+LDFLAGS+= -L${LOCALBASE}/lib
+MAKE_JOBS_UNSAFE=yes
+
+PLIST_FILES= lib/libcrm114.so \
+ lib/libcrm114.so.0 \
+ include/crm114_config.h \
+ include/crm114_lib.h \
+ include/crm114_structs.h \
+ include/crm114_sysincludes.h \
+ share/doc/libcrm114/HOWTO.txt \
+ share/doc/libcrm114/simple_demo.c
+PLIST_DIRS= share/doc/libcrm114
+
+.include <bsd.port.mk>