aboutsummaryrefslogtreecommitdiff
path: root/textproc/liblingoteach
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2003-11-18 04:23:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2003-11-18 04:23:36 +0000
commitb26260296615e0b0cde7ec9727327d2f20f3d3f9 (patch)
tree280771e9a5d8b0b14c7f32887ee913fe309eea8c /textproc/liblingoteach
parentb13871449d6a56b1b3076a300057e079eabfe2ff (diff)
downloadports-b26260296615e0b0cde7ec9727327d2f20f3d3f9.tar.gz
ports-b26260296615e0b0cde7ec9727327d2f20f3d3f9.zip
Notes
Diffstat (limited to 'textproc/liblingoteach')
-rw-r--r--textproc/liblingoteach/Makefile40
-rw-r--r--textproc/liblingoteach/distinfo1
-rw-r--r--textproc/liblingoteach/files/patch-doc-Makefile.in11
-rw-r--r--textproc/liblingoteach/pkg-descr5
-rw-r--r--textproc/liblingoteach/pkg-plist31
5 files changed, 88 insertions, 0 deletions
diff --git a/textproc/liblingoteach/Makefile b/textproc/liblingoteach/Makefile
new file mode 100644
index 000000000000..6c57f0860412
--- /dev/null
+++ b/textproc/liblingoteach/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: liblingoteach
+# Date created: 14 October 2003
+# Whom: Marcus von Appen
+#
+# $FreeBSD$
+#
+
+PORTNAME= liblingoteach
+PORTVERSION= 0.2.0
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= lingoteach
+
+MAINTAINER= mva@sysfault.org
+COMMENT= A library for parsing lesson files based on the LingoTeach DTD
+
+USE_GMAKE= yes
+USE_GNOME= gnomehack gnometarget libxml2
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+.if defined(WITH_COMP)
+CONFIGURE_ARGS+= --with-compression
+.endif
+
+.if defined(WITH_DEBUG)
+CONFIGURE_ARGS+= --enable-debug
+.endif
+
+pre-everything::
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "liblingoteach can be used with the following switches:"
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} " WITH_COMP=yes Enables zlib compression of"
+ @${ECHO_MSG} " the lesson files"
+ @${ECHO_MSG} " WITH_DEBUG=yes Enables additional debugging"
+ @${ECHO_MSG} " information and output"
+ @${ECHO_MSG} ""
+
+.include <bsd.port.mk>
diff --git a/textproc/liblingoteach/distinfo b/textproc/liblingoteach/distinfo
new file mode 100644
index 000000000000..206625b168f0
--- /dev/null
+++ b/textproc/liblingoteach/distinfo
@@ -0,0 +1 @@
+MD5 (liblingoteach-0.2.0.tar.gz) = 49c3824d1b74a3fd69bdec7ff689a877
diff --git a/textproc/liblingoteach/files/patch-doc-Makefile.in b/textproc/liblingoteach/files/patch-doc-Makefile.in
new file mode 100644
index 000000000000..12f40b6da58f
--- /dev/null
+++ b/textproc/liblingoteach/files/patch-doc-Makefile.in
@@ -0,0 +1,11 @@
+--- doc/Makefile.in.orig Sun Oct 12 13:30:43 2003
++++ doc/Makefile.in Tue Oct 14 23:35:13 2003
+@@ -88,7 +88,7 @@
+ am__quote = @am__quote@
+ install_sh = @install_sh@
+
+-DOC_MODULE = liblingoteach-$(VERSION)
++DOC_MODULE = liblingoteach
+ HTML_DIR = $(datadir)/doc
+ subdir = doc
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/textproc/liblingoteach/pkg-descr b/textproc/liblingoteach/pkg-descr
new file mode 100644
index 000000000000..d21ab61e0cd9
--- /dev/null
+++ b/textproc/liblingoteach/pkg-descr
@@ -0,0 +1,5 @@
+This is a port of liblingoteach, a library for special translation
+lesson interaction. It uses the LingoTeach DTD format for general
+validation.
+
+WWW: http://www.lingoteach.org
diff --git a/textproc/liblingoteach/pkg-plist b/textproc/liblingoteach/pkg-plist
new file mode 100644
index 000000000000..b3f6bf20d008
--- /dev/null
+++ b/textproc/liblingoteach/pkg-plist
@@ -0,0 +1,31 @@
+include/lingoteach/lingdefs.h
+include/lingoteach/lingoteach.h
+lib/liblingoteach.a
+lib/liblingoteach.so
+lib/liblingoteach.so.0
+libdata/pkgconfig/liblingoteach.pc
+share/doc/liblingoteach/html/a00009.html
+share/doc/liblingoteach/html/a00010.html
+share/doc/liblingoteach/html/a00011.html
+share/doc/liblingoteach/html/a00012.html
+share/doc/liblingoteach/html/a00013.html
+share/doc/liblingoteach/html/a00014.html
+share/doc/liblingoteach/html/a00015.html
+share/doc/liblingoteach/html/a00016.html
+share/doc/liblingoteach/html/a00017.html
+share/doc/liblingoteach/html/annotated.html
+share/doc/liblingoteach/html/classes.html
+share/doc/liblingoteach/html/doxygen.css
+share/doc/liblingoteach/html/doxygen.png
+share/doc/liblingoteach/html/files.html
+share/doc/liblingoteach/html/functions.html
+share/doc/liblingoteach/html/functions_vars.html
+share/doc/liblingoteach/html/globals.html
+share/doc/liblingoteach/html/globals_enum.html
+share/doc/liblingoteach/html/globals_eval.html
+share/doc/liblingoteach/html/globals_func.html
+share/doc/liblingoteach/html/globals_type.html
+share/doc/liblingoteach/html/index.html
+@dirrm share/doc/liblingoteach/html
+@dirrm share/doc/liblingoteach
+@dirrm include/lingoteach