aboutsummaryrefslogtreecommitdiff
path: root/textproc/libtranslate/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-02-09 19:12:05 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-02-09 19:12:05 +0000
commit08dbdcc7543bd9d5e38b5c7fdf6e720536d338dd (patch)
tree4c662e7c4db719c5122eb083e4f6f662b6e843db /textproc/libtranslate/Makefile
parent670a4fe453eaa0e51e3612c944dacfec9e21baa0 (diff)
downloadports-08dbdcc7543bd9d5e38b5c7fdf6e720536d338dd.tar.gz
ports-08dbdcc7543bd9d5e38b5c7fdf6e720536d338dd.zip
Notes
Diffstat (limited to 'textproc/libtranslate/Makefile')
-rw-r--r--textproc/libtranslate/Makefile52
1 files changed, 52 insertions, 0 deletions
diff --git a/textproc/libtranslate/Makefile b/textproc/libtranslate/Makefile
new file mode 100644
index 000000000000..6a84e4e6c970
--- /dev/null
+++ b/textproc/libtranslate/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: libtranslate
+# Date created: 15 Jan 2005
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtranslate
+PORTVERSION= 0.99
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A natural language translation library
+
+USE_GETOPT_LONG= yes
+USE_GNOME= glib20 gnomehack intlhack
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+
+OPTIONS= GENERIC "generic module" on \
+ TALKFILTERS "talkfilters module" on
+
+MAN1= translate.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_GENERIC)
+CONFIGURE_ARGS+= --disable-generic
+PLIST_SUB+= GENERIC="@comment "
+.else
+PLIST_SUB+= GENERIC=""
+USE_GNOME+= libxml2
+LIB_DEPENDS+= soup-2.2:${PORTSDIR}/devel/libsoup
+MAN5+= services.xml.5
+.endif
+
+.if defined(WITHOUT_TALKFILTERS)
+CONFIGURE_ARGS+= --disable-talkfilters
+PLIST_SUB+= TALKFILTERS="@comment "
+.else
+PLIST_SUB+= TALKFILTERS=""
+LIB_DEPENDS+= talkfilters:${PORTSDIR}/misc/talkfilters
+.endif
+
+.include <bsd.port.post.mk>