aboutsummaryrefslogtreecommitdiff
path: root/textproc/libtranslate
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-02-09 19:12:05 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-02-09 19:12:05 +0000
commit08dbdcc7543bd9d5e38b5c7fdf6e720536d338dd (patch)
tree4c662e7c4db719c5122eb083e4f6f662b6e843db /textproc/libtranslate
parent670a4fe453eaa0e51e3612c944dacfec9e21baa0 (diff)
downloadports-08dbdcc7543bd9d5e38b5c7fdf6e720536d338dd.tar.gz
ports-08dbdcc7543bd9d5e38b5c7fdf6e720536d338dd.zip
Notes
Diffstat (limited to 'textproc/libtranslate')
-rw-r--r--textproc/libtranslate/Makefile52
-rw-r--r--textproc/libtranslate/distinfo2
-rw-r--r--textproc/libtranslate/pkg-descr17
-rw-r--r--textproc/libtranslate/pkg-plist42
4 files changed, 113 insertions, 0 deletions
diff --git a/textproc/libtranslate/Makefile b/textproc/libtranslate/Makefile
new file mode 100644
index 000000000000..6a84e4e6c970
--- /dev/null
+++ b/textproc/libtranslate/Makefile
@@ -0,0 +1,52 @@
+# New ports collection makefile for: libtranslate
+# Date created: 15 Jan 2005
+# Whom: Jean-Yves Lefort <jylefort@brutele.be>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtranslate
+PORTVERSION= 0.99
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SAVANNAH}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= jylefort@brutele.be
+COMMENT= A natural language translation library
+
+USE_GETOPT_LONG= yes
+USE_GNOME= glib20 gnomehack intlhack
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALLS_SHLIB= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
+
+OPTIONS= GENERIC "generic module" on \
+ TALKFILTERS "talkfilters module" on
+
+MAN1= translate.1
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_GENERIC)
+CONFIGURE_ARGS+= --disable-generic
+PLIST_SUB+= GENERIC="@comment "
+.else
+PLIST_SUB+= GENERIC=""
+USE_GNOME+= libxml2
+LIB_DEPENDS+= soup-2.2:${PORTSDIR}/devel/libsoup
+MAN5+= services.xml.5
+.endif
+
+.if defined(WITHOUT_TALKFILTERS)
+CONFIGURE_ARGS+= --disable-talkfilters
+PLIST_SUB+= TALKFILTERS="@comment "
+.else
+PLIST_SUB+= TALKFILTERS=""
+LIB_DEPENDS+= talkfilters:${PORTSDIR}/misc/talkfilters
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/libtranslate/distinfo b/textproc/libtranslate/distinfo
new file mode 100644
index 000000000000..95fe1e215f9e
--- /dev/null
+++ b/textproc/libtranslate/distinfo
@@ -0,0 +1,2 @@
+MD5 (libtranslate-0.99.tar.gz) = 1fe75a6a6e8a0c6518890b5fa6984d42
+SIZE (libtranslate-0.99.tar.gz) = 532516
diff --git a/textproc/libtranslate/pkg-descr b/textproc/libtranslate/pkg-descr
new file mode 100644
index 000000000000..c913b416703a
--- /dev/null
+++ b/textproc/libtranslate/pkg-descr
@@ -0,0 +1,17 @@
+libtranslate is a library for translating text and web pages between
+natural languages. Its modular infrastructure allows to implement new
+translation services separately from the core library.
+
+libtranslate is shipped with a generic module supporting web-based
+translation services such as Babel Fish, Google Language Tools and
+SYSTRAN. Moreover, the generic module allows to add new services
+simply by adding a few lines to a XML file (see the services.xml(5)
+manual page).
+
+The libtranslate distribution includes a powerful command line
+interface (see the translate(1) manual page).
+
+WWW: http://www.nongnu.org/libtranslate/
+
+- Jean-Yves Lefort
+jylefort@brutele.be
diff --git a/textproc/libtranslate/pkg-plist b/textproc/libtranslate/pkg-plist
new file mode 100644
index 000000000000..6fb2b15e5bc9
--- /dev/null
+++ b/textproc/libtranslate/pkg-plist
@@ -0,0 +1,42 @@
+bin/translate
+include/libtranslate/translate-common.h
+include/libtranslate/translate-pair.h
+include/libtranslate/translate-service.h
+include/libtranslate/translate-session.h
+include/libtranslate/translate-util.h
+include/libtranslate/translate.h
+lib/libtranslate.a
+lib/libtranslate.so
+lib/libtranslate.so.0
+%%GENERIC%%lib/libtranslate/modules/generic.so
+%%TALKFILTERS%%lib/libtranslate/modules/talkfilters.so
+libdata/pkgconfig/libtranslate.pc
+share/doc/libtranslate/TranslatePair.html
+share/doc/libtranslate/TranslateService.html
+share/doc/libtranslate/TranslateSession.html
+share/doc/libtranslate/api-reference.html
+share/doc/libtranslate/ch01s02.html
+share/doc/libtranslate/ch02s02.html
+share/doc/libtranslate/compiling-modules.html
+share/doc/libtranslate/home.png
+share/doc/libtranslate/index.html
+share/doc/libtranslate/index.sgml
+share/doc/libtranslate/ix01.html
+share/doc/libtranslate/left.png
+share/doc/libtranslate/libtranslate-translate-common.html
+share/doc/libtranslate/libtranslate-translate-util.html
+share/doc/libtranslate/libtranslate-translate.html
+share/doc/libtranslate/libtranslate.devhelp
+share/doc/libtranslate/overview.html
+share/doc/libtranslate/rfc3066-builtin.html
+share/doc/libtranslate/right.png
+share/doc/libtranslate/tutorials.html
+share/doc/libtranslate/up.png
+share/libtranslate/services.dtd
+share/libtranslate/services.xml
+share/locale/fr/LC_MESSAGES/libtranslate.mo
+@dirrm include/libtranslate
+@dirrm lib/libtranslate/modules
+@dirrm lib/libtranslate
+@dirrm share/doc/libtranslate
+@dirrm share/libtranslate