aboutsummaryrefslogtreecommitdiff
path: root/textproc/libwps
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-03-30 22:11:50 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-03-30 22:11:50 +0000
commitebdb7828af716f6cfc0a813f88c119d218b78dc6 (patch)
treeed104d332316ea28da4292c2af39ab07212c35b7 /textproc/libwps
parent291ab0a5341eef5853b6d3af39010e7e1f1bcecf (diff)
downloadports-ebdb7828af716f6cfc0a813f88c119d218b78dc6.tar.gz
ports-ebdb7828af716f6cfc0a813f88c119d218b78dc6.zip
Notes
Diffstat (limited to 'textproc/libwps')
-rw-r--r--textproc/libwps/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/textproc/libwps/Makefile b/textproc/libwps/Makefile
index 3a881309656b..207c82649c45 100644
--- a/textproc/libwps/Makefile
+++ b/textproc/libwps/Makefile
@@ -13,7 +13,6 @@ COMMENT= Microsoft file word processor format import filter library
LICENSE= LGPL21 MPL
LICENSE_COMB= dual
-BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
LIB_DEPENDS= libwpd-0.9.so:${PORTSDIR}/textproc/libwpd
OPTIONS_DEFINE= DOCS
@@ -21,10 +20,19 @@ OPTIONS_DEFINE= DOCS
CONFIGURE_ARGS= --disable-werror
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
-USES= libtool pkgconfig pathfix
+USES= libtool pkgconfig pathfix compiler:features
USE_LDCONFIG= yes
PORTDOCS= *
DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
DOCS_CONFIGURE_OFF= --without-docs
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${COMPILER_FEATURES:Mlibc++}
+CONFIGURE_ARGS= --with-sharedptr=c++11
+.else
+BUILD_DEPENDS+= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost-libs
+CONFIGURE_ARGS= --with-sharedptr=boost
+.endif
+
+.include <bsd.port.post.mk>