aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxml++/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 12:57:21 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-11-20 12:57:21 +0000
commit79c373120d47d2de4693e5ded0a6082a5d693721 (patch)
treed2c2e64415f2e699ce81e61460a171c5f25ee27d /textproc/libxml++/Makefile
parent19977704ff2106ed1bc62f38e5cb6bbfb581273f (diff)
Notes
Diffstat (limited to 'textproc/libxml++/Makefile')
-rw-r--r--textproc/libxml++/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/textproc/libxml++/Makefile b/textproc/libxml++/Makefile
index a3d4a4a938b0..1bdad9d5af06 100644
--- a/textproc/libxml++/Makefile
+++ b/textproc/libxml++/Makefile
@@ -7,17 +7,22 @@
#
PORTNAME= libxml++
-PORTVERSION= 0.14.p2
+PORTVERSION= 0.15.0
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME:S/+/plus/g}
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.p/pre/}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+USE_REINPLACE= yes
USE_LIBTOOL= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
+post-patch:
+ @${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
+
.include <bsd.port.mk>