aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxml2/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-15 02:31:28 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2003-08-15 02:31:28 +0000
commit982aa704c10b267d6ec53fb545edd2dde57b8324 (patch)
tree08b1c1ff196da97f945c0ab7b0c9760b55807ff2 /textproc/libxml2/Makefile
parentb67a28791a0371d8bde0cfa4e774b3aac5411530 (diff)
Notes
Diffstat (limited to 'textproc/libxml2/Makefile')
-rw-r--r--textproc/libxml2/Makefile10
1 files changed, 6 insertions, 4 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index ac9f8375c231..3feac8619e9e 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libxml2
-PORTVERSION= 2.5.9
+PORTVERSION= 2.5.10
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.5
@@ -26,7 +26,7 @@ USE_REINPLACE= yes
CONFIGURE_ARGS= --with-iconv=${LOCALBASE} \
--with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+ LDFLAGS="-L${LOCALBASE}/lib"
MAN1= xml2-config.1 xmllint.1 xmlcatalog.1
MAN3= libxml.3
@@ -34,6 +34,7 @@ MAN3= libxml.3
.if !defined(WITHOUT_PYTHON)
USE_PYTHON= yes
PLIST_SUB+= PYTHON:=""
+CONFIGURE_ARGS+= --with-python=${LOCALBASE}
.else
CONFIGURE_ARGS+= --without-python
PLIST_SUB+= PYTHON:="@comment "
@@ -69,12 +70,13 @@ pre-everything::
@${ECHO_MSG} " WITHOUT_PYTHON=yes Turns off Python support"
@${ECHO_MSG} " WITH_THREADS=yes Turns on pthread support"
@${ECHO_MSG} " WITH_SCHEMA=yes Turns on XML Schema support"
- @${ECHO_MSG} " WITH_MEM_DEBUG=yes Turns on memory debugging"
+ @${ECHO_MSG} " WITH_MEM_DEBUG=yes Turns on memory debugging (DEVELOPERS ONLY!)"
@${ECHO_MSG} " WITH_XMLLINT_HIST=yes Turns on history for xmllint"
- @${ECHO_MSG} " WITH_THREAD_ALLOC=yes Turns on per-thread memory"
+ @${ECHO_MSG} " WITH_THREAD_ALLOC=yes Turns on per-thread memory (DEVELOPERS ONLY!)"
@${ECHO_MSG} ""
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/catalog.c ${WRKSRC}/xmlcatalog.c
+
.include <bsd.port.mk>