aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxml2
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-11-15 16:29:26 +0000
committerAde Lovett <ade@FreeBSD.org>2000-11-15 16:29:26 +0000
commit5ab6c2fc42d15dd3bc0c5e1d9d25f2cad52176da (patch)
treefb6639d778a32280b09790395de52e9074248843 /textproc/libxml2
parent7102926a312e7d8f1dd4018bc1d54bf7aac7410e (diff)
downloadports-5ab6c2fc42d15dd3bc0c5e1d9d25f2cad52176da.tar.gz
ports-5ab6c2fc42d15dd3bc0c5e1d9d25f2cad52176da.zip
Notes
Diffstat (limited to 'textproc/libxml2')
-rw-r--r--textproc/libxml2/Makefile8
-rw-r--r--textproc/libxml2/files/patch-aa108
-rw-r--r--textproc/libxml2/files/patch-ab13
-rw-r--r--textproc/libxml2/files/patch-ac22
-rw-r--r--textproc/libxml2/files/patch-ad20
-rw-r--r--textproc/libxml2/pkg-plist120
6 files changed, 212 insertions, 79 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index 87570d1f6f17..508356c8a48d 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libxml2
PORTVERSION= 2.2.8
+PORTREVISION= 1
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/libxml
@@ -23,7 +24,12 @@ CONFIGURE_ARGS= --with-iconv
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -liconv"
-MAN1= xml-config.1 xmllint.1
+MAN1= xml2-config.1 xmllint.1
MAN4= libxml.4
+pre-patch:
+ @find ${WRKSRC}/include -type f -name "*.h" | \
+ xargs ${PERL} -pi -e 's|libxml/|libxml2/|'
+ @${LN} -sf ${WRKSRC}/include/libxml ${WRKSRC}/include/libxml2
+
.include <bsd.port.mk>
diff --git a/textproc/libxml2/files/patch-aa b/textproc/libxml2/files/patch-aa
index 31fc3d93ddfc..f6494ed73746 100644
--- a/textproc/libxml2/files/patch-aa
+++ b/textproc/libxml2/files/patch-aa
@@ -1,44 +1,116 @@
---- Makefile.in.orig Sun Oct 15 15:37:34 2000
-+++ Makefile.in Sun Oct 15 16:55:55 2000
-@@ -124,3 +124,3 @@
+--- Makefile.in.orig Mon Nov 13 20:28:42 2000
++++ Makefile.in Wed Nov 15 12:41:10 2000
+@@ -119,20 +119,20 @@
+
+ bin_PROGRAMS = xmllint
+
+-bin_SCRIPTS = xml-config
++bin_SCRIPTS = xml2-config
+
+-lib_LTLIBRARIES = libxml.la
++lib_LTLIBRARIES = libxml2.la
+ libxml_la_LIBADD = @Z_LIBS@
-libxml_la_LDFLAGS = -version-info @LIBXML_VERSION_INFO@
+libxml_la_LDFLAGS = -version-info 5:0:0
-@@ -161,3 +161,3 @@
+ libxml_la_SOURCES = SAX.c entities.c encoding.c error.c parserInternals.c parser.c tree.c hash.c xmlIO.c xmlmemory.c uri.c valid.c xlink.c HTMLparser.c HTMLtree.c debugXML.c xpath.c xpointer.c xinclude.c nanohttp.c nanoftp.c
+
+
+-DEPS = $(top_builddir)/libxml.la
+-LDADDS = $(top_builddir)/libxml.la @Z_LIBS@ @M_LIBS@
++DEPS = $(top_builddir)/libxml2.la
++LDADDS = $(top_builddir)/libxml2.la @Z_LIBS@ @M_LIBS@
+
+-man_MANS = xmllint.1 xml-config.1 libxml.4
++man_MANS = xmllint.1 xml2-config.1 libxml.4
+
+ m4datadir = $(datadir)/aclocal m4data_DATA = libxml.m4
+
+@@ -161,10 +161,10 @@
+ testURI_DEPENDENCIES = $(DEPS)
+ testURI_LDADD = $(LDADDS)
-confexecdir = $(libdir)
+-confexec_DATA = xmlConf.sh
+confexecdir = $(sysconfdir)
- confexec_DATA = xmlConf.sh
-@@ -204,3 +204,3 @@
++confexec_DATA = xml2Conf.sh
+
+-CLEANFILES = xmlConf.sh
++CLEANFILES = xml2Conf.sh
+ EXTRA_DIST = xmlConf.sh.in libxml.spec.in libxml.spec libxml.m4 example/Makefile.am example/gjobread.c example/gjobs.xml $(man_MANS) libxml-2.0.pc.in xmlversion.h.in win32/README.MSDev win32/Makefile.mingw win32/libxml2/libxml2.dsp
+
+
+@@ -204,7 +204,7 @@
+ MANS = $(man_MANS)
+
NROFF = nroff
-DATA = $(confexec_DATA) $(pkgconfig_DATA)
+DATA = $(confexec_DATA)
-@@ -782,3 +782,3 @@
+ DIST_COMMON = README ./stamp-h.in AUTHORS COPYING COPYING.LIB ChangeLog \
+ INSTALL Makefile.am Makefile.in NEWS TODO acconfig.h acinclude.m4 \
+@@ -270,6 +270,10 @@
+ cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
+ libxml-2.0.pc: $(top_builddir)/config.status libxml-2.0.pc.in
+ cd $(top_builddir) && CONFIG_FILES=$@ CONFIG_HEADERS= $(SHELL) ./config.status
++xml2-config: xml-config
++ cd $(top_builddir) && cp xml-config xml2-config
++xml2-config.1: xml-config.1
++ cd $(top_builddir) && cp xml-config.1 xml2-config.1
+
+ mostlyclean-libLTLIBRARIES:
+
+@@ -334,7 +338,7 @@
+
+ maintainer-clean-libtool:
+
+-libxml.la: $(libxml_la_OBJECTS) $(libxml_la_DEPENDENCIES)
++libxml2.la: $(libxml_la_OBJECTS) $(libxml_la_DEPENDENCIES)
+ $(LINK) -rpath $(libdir) $(libxml_la_LDFLAGS) $(libxml_la_OBJECTS) $(libxml_la_LIBADD) $(LIBS)
+
+ mostlyclean-binPROGRAMS:
+@@ -805,7 +809,7 @@
+ install-binSCRIPTS install-confexecDATA
+ install-exec: install-exec-recursive
-install-data-am: install-man install-pkgconfigDATA
+install-data-am: install-man
install-data: install-data-recursive
-@@ -792,3 +792,3 @@
+
+ install-am: all-am
+@@ -815,7 +819,7 @@
+ uninstall-binSCRIPTS uninstall-man \
+ uninstall-confexecDATA uninstall-pkgconfigDATA
uninstall: uninstall-recursive
-all-am: Makefile $(LTLIBRARIES) $(PROGRAMS) $(SCRIPTS) $(MANS) $(DATA) \
+all-am: Makefile $(LTLIBRARIES) $(SCRIPTS) $(MANS) $(DATA) \
config.h
-@@ -801,4 +801,3 @@
+ all-redirect: all-recursive-am
+ install-strip:
+@@ -824,8 +828,7 @@
+ installdirs-am:
+ $(mkinstalldirs) $(DESTDIR)$(libdir) $(DESTDIR)$(bindir) \
$(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 \
- $(DESTDIR)$(mandir)/man4 $(DESTDIR)$(confexecdir) \
- $(DESTDIR)$(pkgconfigdir)
+ $(DESTDIR)$(mandir)/man4 $(DESTDIR)$(confexecdir)
---- doc/Makefile.in.orig Thu Feb 25 13:01:51 1999
-+++ doc/Makefile.in Tue Mar 2 20:39:23 1999
-@@ -89,7 +89,7 @@
- # The directory containing the source code (if it contains documentation).
- DOC_SOURCE_DIR = ..
--HTML_DIR = $(datadir)/gnome-xml/html
-+HTML_DIR = $(datadir)
+ mostlyclean-generic:
+@@ -1196,13 +1199,13 @@
+ rpm: $(distdir).tar.gz
+ rpm -ta $(distdir).tar.gz
+
+-xmlConf.sh: xmlConf.sh.in Makefile
++xml2Conf.sh: xmlConf.sh.in Makefile
+ sed -e 's?\@XML_LIBDIR\@?$(XML_LIBDIR)?g' \
+ -e 's?\@XML_INCLUDEDIR\@?$(XML_INCLUDEDIR)?g' \
+ -e 's?\@XML_LIBS\@?$(XML_LIBS)?g' \
+ -e 's?\@VERSION\@?$(VERSION)?g' \
+ < $(srcdir)/xmlConf.sh.in > xmlConf.tmp \
+- && mv xmlConf.tmp xmlConf.sh
++ && mv xmlConf.tmp xml2Conf.sh
- TARGET_DIR = $(HTML_DIR)/$(DOC_MODULE)
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/textproc/libxml2/files/patch-ab b/textproc/libxml2/files/patch-ab
new file mode 100644
index 000000000000..53faf2f4006d
--- /dev/null
+++ b/textproc/libxml2/files/patch-ab
@@ -0,0 +1,13 @@
+--- configure 2000/11/15 09:47:14 1.1
++++ configure 2000/11/15 09:51:34
+@@ -3419,8 +3419,8 @@
+
+
+ XML_LIBDIR='-L${libdir}'
+-XML_INCLUDEDIR='-I${includedir}/libxml -I${includedir}'
+-XML_LIBS="-lxml $Z_LIBS $M_LIBS $LIBS"
++XML_INCLUDEDIR='-I${includedir}/libxml2 -I${includedir}'
++XML_LIBS="-lxml2 $Z_LIBS $M_LIBS $LIBS"
+
+ XML_CFLAGS=""
+
diff --git a/textproc/libxml2/files/patch-ac b/textproc/libxml2/files/patch-ac
new file mode 100644
index 000000000000..1b305d6e71d3
--- /dev/null
+++ b/textproc/libxml2/files/patch-ac
@@ -0,0 +1,22 @@
+--- include/Makefile.in 2000/11/15 09:53:28 1.1
++++ include/Makefile.in 2000/11/15 10:12:23
+@@ -143,8 +143,8 @@
+ $(mkinstalldirs) $(DESTDIR)$(xmlincdir)
+ @list='$(xmlinc_HEADERS)'; for p in $$list; do \
+ if test -f "$$p"; then d= ; else d="$(srcdir)/"; fi; \
+- echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(xmlincdir)/$$p"; \
+- $(INSTALL_DATA) $$d$$p $(DESTDIR)$(xmlincdir)/$$p; \
++ echo " $(INSTALL_DATA) $$d$$p $(DESTDIR)$(xmlincdir)/`echo $$p | sed 's|libxml/|libxml2/|'`"; \
++ $(INSTALL_DATA) $$d$$p $(DESTDIR)$(xmlincdir)/`echo $$p | sed 's|libxml/|libxml2/|'`; \
+ done
+
+ uninstall-xmlincHEADERS:
+@@ -266,7 +266,7 @@
+
+
+ install-exec-hook:
+- $(mkinstalldirs) $(DESTDIR)$(xmlincdir) $(DESTDIR)$(xmlincdir)/libxml
++ $(mkinstalldirs) $(DESTDIR)$(xmlincdir) $(DESTDIR)$(xmlincdir)/libxml2
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
diff --git a/textproc/libxml2/files/patch-ad b/textproc/libxml2/files/patch-ad
new file mode 100644
index 000000000000..5c12cf1afc30
--- /dev/null
+++ b/textproc/libxml2/files/patch-ad
@@ -0,0 +1,20 @@
+--- doc/Makefile.in.orig Mon Nov 13 20:28:44 2000
++++ doc/Makefile.in Wed Nov 15 12:50:29 2000
+@@ -112,7 +112,7 @@
+ Z_CFLAGS = @Z_CFLAGS@
+ Z_LIBS = @Z_LIBS@
+
+-DOC_MODULE = gnome-xml
++DOC_MODULE = gnome-xml2
+
+ # The top-level SGML file.
+ DOC_MAIN_SGML_FILE = gnome-xml.sgml
+@@ -120,7 +120,7 @@
+ # The directory containing the source code (if it contains documentation).
+ DOC_SOURCE_DIR = ..
+
+-HTML_DIR = $(datadir)/gnome-xml/html
++HTML_DIR = $(datadir)
+
+ TARGET_DIR = $(HTML_DIR)/$(DOC_MODULE)
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
diff --git a/textproc/libxml2/pkg-plist b/textproc/libxml2/pkg-plist
index dd6c0fa5df74..0e31ffc63479 100644
--- a/textproc/libxml2/pkg-plist
+++ b/textproc/libxml2/pkg-plist
@@ -1,61 +1,61 @@
-bin/xml-config
+bin/xml2-config
bin/xmllint
-etc/xmlConf.sh
-include/libxml/HTMLparser.h
-include/libxml/HTMLtree.h
-include/libxml/SAX.h
-include/libxml/debugXML.h
-include/libxml/encoding.h
-include/libxml/entities.h
-include/libxml/hash.h
-include/libxml/nanoftp.h
-include/libxml/nanohttp.h
-include/libxml/parser.h
-include/libxml/parserInternals.h
-include/libxml/tree.h
-include/libxml/uri.h
-include/libxml/valid.h
-include/libxml/xinclude.h
-include/libxml/xlink.h
-include/libxml/xmlIO.h
-include/libxml/xmlerror.h
-include/libxml/xmlmemory.h
-include/libxml/xmlversion.h
-include/libxml/xpath.h
-include/libxml/xpathInternals.h
-include/libxml/xpointer.h
-lib/libxml.a
-lib/libxml.so
-lib/libxml.so.5
-share/gnome-xml/DOM.gif
-share/gnome-xml/FAQ.html
-share/gnome-xml/book1.html
-share/gnome-xml/encoding.html
-share/gnome-xml/gnome-xml-debugxml.html
-share/gnome-xml/gnome-xml-encoding.html
-share/gnome-xml/gnome-xml-entities.html
-share/gnome-xml/gnome-xml-error.html
-share/gnome-xml/gnome-xml-htmlparser.html
-share/gnome-xml/gnome-xml-htmltree.html
-share/gnome-xml/gnome-xml-nanoftp.html
-share/gnome-xml/gnome-xml-nanohttp.html
-share/gnome-xml/gnome-xml-parser.html
-share/gnome-xml/gnome-xml-parserinternals.html
-share/gnome-xml/gnome-xml-sax.html
-share/gnome-xml/gnome-xml-tree.html
-share/gnome-xml/gnome-xml-uri.html
-share/gnome-xml/gnome-xml-valid.html
-share/gnome-xml/gnome-xml-xinclude.html
-share/gnome-xml/gnome-xml-xml-error.html
-share/gnome-xml/gnome-xml-xmlio.html
-share/gnome-xml/gnome-xml-xmlmemory.html
-share/gnome-xml/gnome-xml-xpath.html
-share/gnome-xml/gnome-xml-xpathinternals.html
-share/gnome-xml/gnome-xml-xpointer.html
-share/gnome-xml/index.sgml
-share/gnome-xml/libxml-lib.html
-share/gnome-xml/libxml-notes.html
-share/gnome-xml/structure.gif
-share/gnome-xml/xml.html
-@dirrm share/gnome-xml
-@dirrm include/libxml
+etc/xml2Conf.sh
+include/libxml2/HTMLparser.h
+include/libxml2/HTMLtree.h
+include/libxml2/SAX.h
+include/libxml2/debugXML.h
+include/libxml2/encoding.h
+include/libxml2/entities.h
+include/libxml2/hash.h
+include/libxml2/nanoftp.h
+include/libxml2/nanohttp.h
+include/libxml2/parser.h
+include/libxml2/parserInternals.h
+include/libxml2/tree.h
+include/libxml2/uri.h
+include/libxml2/valid.h
+include/libxml2/xinclude.h
+include/libxml2/xlink.h
+include/libxml2/xmlIO.h
+include/libxml2/xmlerror.h
+include/libxml2/xmlmemory.h
+include/libxml2/xmlversion.h
+include/libxml2/xpath.h
+include/libxml2/xpathInternals.h
+include/libxml2/xpointer.h
+lib/libxml2.a
+lib/libxml2.so
+lib/libxml2.so.5
+share/gnome-xml2/DOM.gif
+share/gnome-xml2/FAQ.html
+share/gnome-xml2/book1.html
+share/gnome-xml2/encoding.html
+share/gnome-xml2/gnome-xml-debugxml.html
+share/gnome-xml2/gnome-xml-encoding.html
+share/gnome-xml2/gnome-xml-entities.html
+share/gnome-xml2/gnome-xml-error.html
+share/gnome-xml2/gnome-xml-htmlparser.html
+share/gnome-xml2/gnome-xml-htmltree.html
+share/gnome-xml2/gnome-xml-nanoftp.html
+share/gnome-xml2/gnome-xml-nanohttp.html
+share/gnome-xml2/gnome-xml-parser.html
+share/gnome-xml2/gnome-xml-parserinternals.html
+share/gnome-xml2/gnome-xml-sax.html
+share/gnome-xml2/gnome-xml-tree.html
+share/gnome-xml2/gnome-xml-uri.html
+share/gnome-xml2/gnome-xml-valid.html
+share/gnome-xml2/gnome-xml-xinclude.html
+share/gnome-xml2/gnome-xml-xml-error.html
+share/gnome-xml2/gnome-xml-xmlio.html
+share/gnome-xml2/gnome-xml-xmlmemory.html
+share/gnome-xml2/gnome-xml-xpath.html
+share/gnome-xml2/gnome-xml-xpathinternals.html
+share/gnome-xml2/gnome-xml-xpointer.html
+share/gnome-xml2/index.sgml
+share/gnome-xml2/libxml-lib.html
+share/gnome-xml2/libxml-notes.html
+share/gnome-xml2/structure.gif
+share/gnome-xml2/xml.html
+@dirrm share/gnome-xml2
+@dirrm include/libxml2