aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxml2
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2002-11-25 14:40:29 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2002-11-25 14:40:29 +0000
commit4b5db6201af450c25b86c59865375b4d97ebe590 (patch)
tree2ab862e237afd50e89e12d93885b27dfc72df4a0 /textproc/libxml2
parent035db3c6e4d1825488dc58def45e113d0ef80a88 (diff)
downloadports-4b5db6201af450c25b86c59865375b4d97ebe590.tar.gz
ports-4b5db6201af450c25b86c59865375b4d97ebe590.zip
Notes
Diffstat (limited to 'textproc/libxml2')
-rw-r--r--textproc/libxml2/Makefile1
-rw-r--r--textproc/libxml2/files/patch-parser.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/textproc/libxml2/Makefile b/textproc/libxml2/Makefile
index d2bf16c64542..19ad6b60b898 100644
--- a/textproc/libxml2/Makefile
+++ b/textproc/libxml2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libxml2
PORTVERSION= 2.4.28
+PORTREVISION= 1
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.4
diff --git a/textproc/libxml2/files/patch-parser.c b/textproc/libxml2/files/patch-parser.c
new file mode 100644
index 000000000000..2582f29acb77
--- /dev/null
+++ b/textproc/libxml2/files/patch-parser.c
@@ -0,0 +1,11 @@
+--- parser.c.orig Mon Nov 25 00:39:37 2002
++++ parser.c Mon Nov 25 01:49:31 2002
+@@ -9820,7 +9820,7 @@
+ ctxt->myDoc = oldctxt->myDoc;
+ content = ctxt->myDoc->children;
+ }
+- ctxt->myDoc->children = xmlNewDocNode(newDoc, NULL,
++ ctxt->myDoc->children = xmlNewDocNode(ctxt->myDoc, NULL,
+ BAD_CAST "pseudoroot", NULL);
+ if (ctxt->myDoc->children == NULL) {
+ ctxt->sax = oldsax;