aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxslt/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2001-02-09 23:19:44 +0000
committerAde Lovett <ade@FreeBSD.org>2001-02-09 23:19:44 +0000
commit11c716a03ad6f68cec2bf57b140c7922fc63e6f4 (patch)
treea2406568237b235605e0d9e8637bdb3035d81200 /textproc/libxslt/Makefile
parente313b3998d37dd4d4de39fef804ddb3f3eb80cfb (diff)
downloadports-11c716a03ad6f68cec2bf57b140c7922fc63e6f4.tar.gz
ports-11c716a03ad6f68cec2bf57b140c7922fc63e6f4.zip
Notes
Diffstat (limited to 'textproc/libxslt/Makefile')
-rw-r--r--textproc/libxslt/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/textproc/libxslt/Makefile b/textproc/libxslt/Makefile
new file mode 100644
index 000000000000..cbbd694667db
--- /dev/null
+++ b/textproc/libxslt/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: libxslt
+# Date created: 9th February 2001
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxslt
+PORTVERSION= 0.1.0
+CATEGORIES= textproc gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/libxslt
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+INSTALLS_SHLIB= yes
+
+pre-patch:
+ @find ${WRKSRC} -type f -name "*.[ch]" | \
+ xargs ${PERL} -pi -e 's|libxml/|libxml2/|'
+
+.include <bsd.port.mk>