aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxslt/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-02-26 19:02:58 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-02-26 19:02:58 +0000
commit2224823c69a70a07890956f50558ee5364b06066 (patch)
tree95cca7e55994b7f8268ebbfd0a475e1654d68775 /textproc/libxslt/Makefile
parent4bb4af568010bc38e60359b0653c659d46f99b98 (diff)
Notes
Diffstat (limited to 'textproc/libxslt/Makefile')
-rw-r--r--textproc/libxslt/Makefile18
1 files changed, 17 insertions, 1 deletions
diff --git a/textproc/libxslt/Makefile b/textproc/libxslt/Makefile
index 298bc98f401c..7ba5b4462efa 100644
--- a/textproc/libxslt/Makefile
+++ b/textproc/libxslt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libxslt
-PORTVERSION= 1.0.10
+PORTVERSION= 1.0.12
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/libxslt
@@ -24,4 +24,20 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
MAN4= libexslt.4 libxslt.4
MAN1= xsltproc.1
+.if !defined(WITHOUT_PYTHON)
+USE_PYTHON= yes
+PLIST_SUB+= PYTHON:=""
+.else
+CONFIGURE_ARGS+= --without-python
+PLIST_SUB+= PYTHON:="@comment "
+PKGNAMESUFFIX= -nopython
+.endif
+
+.if !defined(WITHOUT_PYTHON)
+pre-extract:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "If you don't want Python support, add WITHOUT_PYTHON=yes to command line"
+ @${ECHO_MSG} ""
+.endif
+
.include <bsd.port.mk>