aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxslt/files
diff options
context:
space:
mode:
authorAlexander Nedotsukov <bland@FreeBSD.org>2004-07-06 03:02:16 +0000
committerAlexander Nedotsukov <bland@FreeBSD.org>2004-07-06 03:02:16 +0000
commit1fe0f1a81f1abb233e61bdc77f33ae910a0d3a8e (patch)
treefade10ce12924a4dd9341851c0ccbec9fe1ccf25 /textproc/libxslt/files
parentffb2455c8b68c23798826962a088b2984bdb17b1 (diff)
Notes
Diffstat (limited to 'textproc/libxslt/files')
-rw-r--r--textproc/libxslt/files/patch-configure8
-rw-r--r--textproc/libxslt/files/patch-python::Makefile.in42
-rw-r--r--textproc/libxslt/files/patch-python::tests::Makefile.in2
3 files changed, 34 insertions, 18 deletions
diff --git a/textproc/libxslt/files/patch-configure b/textproc/libxslt/files/patch-configure
index e644cf75e11d..8345e15deb87 100644
--- a/textproc/libxslt/files/patch-configure
+++ b/textproc/libxslt/files/patch-configure
@@ -1,13 +1,5 @@
--- configure.orig Fri Sep 12 08:23:19 2003
+++ configure Fri Sep 12 15:29:42 2003
-@@ -8644,6 +8644,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
@@ -10300,7 +10301,7 @@
fi
if test "$with_python" != ""
diff --git a/textproc/libxslt/files/patch-python::Makefile.in b/textproc/libxslt/files/patch-python::Makefile.in
index ce298bb2a576..02358baf99c6 100644
--- a/textproc/libxslt/files/patch-python::Makefile.in
+++ b/textproc/libxslt/files/patch-python::Makefile.in
@@ -1,14 +1,38 @@
-
-$FreeBSD$
-
---- python/Makefile.in.orig Mon Apr 15 21:07:35 2002
-+++ python/Makefile.in Thu Apr 18 14:23:11 2002
-@@ -129,7 +129,7 @@
- -I$(top_srcdir)
-
+--- python/Makefile.in.orig Fri Jul 2 13:29:57 2004
++++ python/Makefile.in Fri Jul 2 13:34:44 2004
+@@ -49,9 +49,7 @@
+ am__installdirs = $(DESTDIR)$(pythondir)
+ pythonLTLIBRARIES_INSTALL = $(INSTALL)
+ LTLIBRARIES = $(python_LTLIBRARIES)
+-@WITH_PYTHON_TRUE@am__DEPENDENCIES_1 = \
+-@WITH_PYTHON_TRUE@ $(top_builddir)/libxslt/libxslt.la \
+-@WITH_PYTHON_TRUE@ $(top_builddir)/libexslt/libexslt.la
++@WITH_PYTHON_TRUE@am__DEPENDENCIES_1 =
+ @WITH_PYTHON_TRUE@libxsltmod_la_DEPENDENCIES = $(am__DEPENDENCIES_1)
+ am__libxsltmod_la_SOURCES_DIST = libxslt.c types.c libxslt-py.c
+ @WITH_PYTHON_TRUE@am_libxsltmod_la_OBJECTS = libxslt.lo types.lo \
+@@ -237,7 +235,7 @@
+ -I$(top_srcdir) \
+ -I../libexslt
-DOCS_DIR = $(datadir)/doc/libxslt-python-$(LIBXSLT_VERSION)
-+DOCS_DIR = $(datadir)/doc/libxslt-python
++DOCS_DIR = $(datadir)/doc/py-libxslt
# libxsltclass.txt is generated
DOCS = TODO
+ EXTRA_DIST = \
+@@ -250,12 +248,11 @@
+ libxslt-python-api.xml \
+ $(DOCS)
+
+-libxsltmod_la_LDFLAGS = -module -avoid-version -L$(top_builddir)/libxslt/.libs \
+- -L$(top_builddir)/libexslt/.libs
++libxsltmod_la_LDFLAGS = -module -avoid-version
+
+ @WITH_PYTHON_TRUE@mylibs = \
+-@WITH_PYTHON_TRUE@ $(top_builddir)/libxslt/libxslt.la \
+-@WITH_PYTHON_TRUE@ $(top_builddir)/libexslt/libexslt.la
++@WITH_PYTHON_TRUE@ -lxslt \
++@WITH_PYTHON_TRUE@ -lexslt
+ @WITH_PYTHON_TRUE@python_LTLIBRARIES = libxsltmod.la
+ @WITH_PYTHON_TRUE@libxsltmod_la_SOURCES = libxslt.c types.c libxslt-py.c
diff --git a/textproc/libxslt/files/patch-python::tests::Makefile.in b/textproc/libxslt/files/patch-python::tests::Makefile.in
index 80a928dd169d..7abaa6ee5739 100644
--- a/textproc/libxslt/files/patch-python::tests::Makefile.in
+++ b/textproc/libxslt/files/patch-python::tests::Makefile.in
@@ -5,7 +5,7 @@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
-EXAMPLE_DIR = $(datadir)/doc/libxslt-python-$(LIBXSLT_VERSION)/examples
-+EXAMPLE_DIR = $(datadir)/doc/libxslt-python/examples
++EXAMPLE_DIR = $(datadir)/examples/py-libxslt
TESTSPY = \
basic.py \
exslt.py \