aboutsummaryrefslogtreecommitdiff
path: root/textproc/libxslt
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-02-26 19:02:58 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-02-26 19:02:58 +0000
commit2224823c69a70a07890956f50558ee5364b06066 (patch)
tree95cca7e55994b7f8268ebbfd0a475e1654d68775 /textproc/libxslt
parent4bb4af568010bc38e60359b0653c659d46f99b98 (diff)
downloadports-2224823c69a70a07890956f50558ee5364b06066.tar.gz
ports-2224823c69a70a07890956f50558ee5364b06066.zip
Notes
Diffstat (limited to 'textproc/libxslt')
-rw-r--r--textproc/libxslt/Makefile18
-rw-r--r--textproc/libxslt/distinfo2
-rw-r--r--textproc/libxslt/files/patch-aa21
-rw-r--r--textproc/libxslt/files/patch-python::Makefile.in14
-rw-r--r--textproc/libxslt/files/patch-python::tests::Makefile.in14
-rw-r--r--textproc/libxslt/pkg-plist13
6 files changed, 71 insertions, 11 deletions
diff --git a/textproc/libxslt/Makefile b/textproc/libxslt/Makefile
index 298bc98f401c..7ba5b4462efa 100644
--- a/textproc/libxslt/Makefile
+++ b/textproc/libxslt/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libxslt
-PORTVERSION= 1.0.10
+PORTVERSION= 1.0.12
CATEGORIES= textproc gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= stable/sources/libxslt
@@ -24,4 +24,20 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include"
MAN4= libexslt.4 libxslt.4
MAN1= xsltproc.1
+.if !defined(WITHOUT_PYTHON)
+USE_PYTHON= yes
+PLIST_SUB+= PYTHON:=""
+.else
+CONFIGURE_ARGS+= --without-python
+PLIST_SUB+= PYTHON:="@comment "
+PKGNAMESUFFIX= -nopython
+.endif
+
+.if !defined(WITHOUT_PYTHON)
+pre-extract:
+ @${ECHO_MSG} ""
+ @${ECHO_MSG} "If you don't want Python support, add WITHOUT_PYTHON=yes to command line"
+ @${ECHO_MSG} ""
+.endif
+
.include <bsd.port.mk>
diff --git a/textproc/libxslt/distinfo b/textproc/libxslt/distinfo
index ea7290543a82..8482ac9ef142 100644
--- a/textproc/libxslt/distinfo
+++ b/textproc/libxslt/distinfo
@@ -1 +1 @@
-MD5 (libxslt-1.0.10.tar.gz) = e12da6708bb1fdd16faf47390cf39fe9
+MD5 (libxslt-1.0.12.tar.gz) = 9e995964bffbf8b5bb97737ebde1a11c
diff --git a/textproc/libxslt/files/patch-aa b/textproc/libxslt/files/patch-aa
index 4cf4d956de20..491313ec15dc 100644
--- a/textproc/libxslt/files/patch-aa
+++ b/textproc/libxslt/files/patch-aa
@@ -1,27 +1,30 @@
$FreeBSD$
---- Makefile.in.orig Mon Jan 14 20:19:35 2002
-+++ Makefile.in Tue Jan 29 11:49:57 2002
-@@ -115,16 +115,14 @@
- @WITH_DEBUGGER_TRUE@ libxslt \
+--- Makefile.in.orig Mon Feb 11 20:57:11 2002
++++ Makefile.in Tue Feb 26 20:53:28 2002
+@@ -122,17 +122,15 @@
@WITH_DEBUGGER_TRUE@ libexslt \
@WITH_DEBUGGER_TRUE@ xsltproc \
--@WITH_DEBUGGER_TRUE@ tests \
- @WITH_DEBUGGER_TRUE@ doc
+ @WITH_DEBUGGER_TRUE@ doc \
+-@WITH_DEBUGGER_TRUE@ python \
+-@WITH_DEBUGGER_TRUE@ tests
++@WITH_DEBUGGER_TRUE@ @WITH_PYTHON_TRUE@ python
@WITH_DEBUGGER_FALSE@SUBDIRS = @WITH_DEBUGGER_FALSE@\
@WITH_DEBUGGER_FALSE@ libxslt \
@WITH_DEBUGGER_FALSE@ libexslt \
@WITH_DEBUGGER_FALSE@ xsltproc \
--@WITH_DEBUGGER_FALSE@ tests \
- @WITH_DEBUGGER_FALSE@ doc
+ @WITH_DEBUGGER_FALSE@ doc \
+-@WITH_DEBUGGER_FALSE@ python \
+-@WITH_DEBUGGER_FALSE@ tests
++@WITH_DEBUGGER_FALSE@ @WITH_PYTHON_TRUE@ python
-confexecdir = $(libdir)
+confexecdir = $(sysconfdir)
confexec_DATA = xsltConf.sh
bin_SCRIPTS = xslt-config
-@@ -135,7 +133,7 @@
+@@ -143,7 +141,7 @@
win32/libxslt/libxslt_so.dsp win32/libxslt/xsltproc.dsp
diff --git a/textproc/libxslt/files/patch-python::Makefile.in b/textproc/libxslt/files/patch-python::Makefile.in
new file mode 100644
index 000000000000..574f2e707223
--- /dev/null
+++ b/textproc/libxslt/files/patch-python::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- python/Makefile.in 2002/02/26 18:23:19 1.1
++++ python/Makefile.in 2002/02/26 18:23:37
+@@ -129,7 +129,7 @@
+ -I$(top_srcdir)
+
+
+-DOCS_DIR = $(prefix)/share/doc/libxslt-python-$(LIBXML_VERSION)
++DOCS_DIR = $(prefix)/share/doc/libxslt-python
+ DOCS = TODO libxsltclass.txt
+
+ EXTRA_DIST = \
diff --git a/textproc/libxslt/files/patch-python::tests::Makefile.in b/textproc/libxslt/files/patch-python::tests::Makefile.in
new file mode 100644
index 000000000000..cac0d8c76216
--- /dev/null
+++ b/textproc/libxslt/files/patch-python::tests::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- python/tests/Makefile.in 2002/02/26 18:23:19 1.1
++++ python/tests/Makefile.in 2002/02/26 18:23:47
+@@ -117,7 +117,7 @@
+ XSLT_LIBDIR = @XSLT_LIBDIR@
+ XSLT_LIBS = @XSLT_LIBS@
+
+-EXAMPLE_DIR = $(prefix)/share/doc/libxslt-python-$(LIBXSLT_VERSION)/examples
++EXAMPLE_DIR = $(prefix)/share/doc/libxslt-python/examples
+
+ TESTSPY = \
+ basic.py \
diff --git a/textproc/libxslt/pkg-plist b/textproc/libxslt/pkg-plist
index 5584dd1f2219..518226853e8e 100644
--- a/textproc/libxslt/pkg-plist
+++ b/textproc/libxslt/pkg-plist
@@ -30,9 +30,20 @@ lib/libxslt.so.1
lib/libxsltbreakpoint.a
lib/libxsltbreakpoint.so
lib/libxsltbreakpoint.so.1
+%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxslt.py
+%%PYTHON:%%lib/%%PYTHON_VERSION%%/site-packages/libxsltmod.so
libdata/pkgconfig/libxslt.pc
+%%PYTHON:%%share/doc/libxslt-python/TODO
+%%PYTHON:%%share/doc/libxslt-python/libxsltclass.txt
+%%PYTHON:%%share/doc/libxslt-python/examples/basic.py
+%%PYTHON:%%share/doc/libxslt-python/examples/extfunc.py
+%%PYTHON:%%share/doc/libxslt-python/examples/pyxsltproc.py
+%%PYTHON:%%share/doc/libxslt-python/examples/test.xml
+%%PYTHON:%%share/doc/libxslt-python/examples/test.xsl
share/doc/libxslt/html/book1.html
+share/doc/libxslt/html/index.sgml
share/doc/libxslt/html/libxslt-attributes.html
+share/doc/libxslt/html/libxslt-extensions.html
share/doc/libxslt/html/libxslt-functions.html
share/doc/libxslt/html/libxslt-imports.html
share/doc/libxslt/html/libxslt-keys.html
@@ -52,6 +63,8 @@ share/doc/libxslt/html/tutorial/libxslttutorial.html
share/doc/libxslt/html/tutorial/libxslttutorial.xml
@dirrm share/doc/libxslt/html/tutorial
@dirrm share/doc/libxslt/html
+%%PYTHON:%%@dirrm share/doc/libxslt-python/examples
+%%PYTHON:%%@dirrm share/doc/libxslt-python
@dirrm share/doc/libxslt
@dirrm include/libxslt
@dirrm include/libexslt