aboutsummaryrefslogtreecommitdiff
path: root/textproc/link-grammar/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2005-05-22 08:24:33 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2005-05-22 08:24:33 +0000
commitfe3cd0525f2e14057c6a277b2bcb683d0e256d2f (patch)
tree800ac78bd2b7c834e3230098452c16ba36fa4549 /textproc/link-grammar/Makefile
parent2d636e9a5f85260ebd11c411fbe79d9654138b07 (diff)
downloadports-fe3cd0525f2e14057c6a277b2bcb683d0e256d2f.tar.gz
ports-fe3cd0525f2e14057c6a277b2bcb683d0e256d2f.zip
Notes
Diffstat (limited to 'textproc/link-grammar/Makefile')
-rw-r--r--textproc/link-grammar/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/textproc/link-grammar/Makefile b/textproc/link-grammar/Makefile
new file mode 100644
index 000000000000..771d8d7804f4
--- /dev/null
+++ b/textproc/link-grammar/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: link-grammar
+# Date created: 22 May 2005
+# Whom: Mezz <mezz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= link-grammar
+PORTVERSION= 4.1.1
+CATEGORIES= textproc
+MASTER_SITES= http://www.abisource.com/downloads/${PORTNAME}/${PORTVERSION}/
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= A grammar checking library
+
+USE_GNOME= gnometarget
+USE_GMAKE= yes
+USE_REINPLACE= yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+
+DOCS= LICENSE README
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
+ ${WRKSRC}/Makefile.in
+ @${REINPLACE_CMD} -e 's|/words/|/en/words/|g' \
+ ${WRKSRC}/data/en/4.0.dict
+
+.ifndef (NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+.for i in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>