aboutsummaryrefslogtreecommitdiff
path: root/textproc/linux-expat
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2003-11-19 14:11:11 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2003-11-19 14:11:11 +0000
commit947edbcb2d704c45a01a7e62187a0cb65b1e60a8 (patch)
tree04eb8d408cc9fed691b7bbafec7f233d132c84de /textproc/linux-expat
parentf1f617bf6989caa20eed9e2df9ae6af5a880b513 (diff)
downloadports-947edbcb2d704c45a01a7e62187a0cb65b1e60a8.tar.gz
ports-947edbcb2d704c45a01a7e62187a0cb65b1e60a8.zip
Notes
Diffstat (limited to 'textproc/linux-expat')
-rw-r--r--textproc/linux-expat/Makefile29
-rw-r--r--textproc/linux-expat/distinfo.i3862
-rw-r--r--textproc/linux-expat/pkg-descr13
3 files changed, 44 insertions, 0 deletions
diff --git a/textproc/linux-expat/Makefile b/textproc/linux-expat/Makefile
new file mode 100644
index 000000000000..33b7dc709aef
--- /dev/null
+++ b/textproc/linux-expat/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: linux-expat
+# Date created: 2003-07-05
+# Whom: trevor
+#
+# $FreeBSD$
+#
+
+PORTNAME= expat
+PORTVERSION= 1.95.5
+CATEGORIES= textproc linux
+
+MAINTAINER= trevor@FreeBSD.org
+COMMENT= Linux/i386 binary port of Expat XML-parsing library
+
+BUILD_DEPENDS= rpm2cpio:${PORTSDIR}/archivers/rpm2cpio
+
+BASEVERSION= 9
+ONLY_FOR_ARCHS= i386
+RPM_SET= expat-1.95.5-2.i386.rpm
+
+pre-install:
+ ${RM} -rf ${WRKSRC}/tmp
+ ${MKDIR} ${WRKSRC}/tmp
+ cd ${WRKSRC}/tmp; \
+ rpm2cpio < ${DISTDIR}/${DIST_SUBDIR}/${RPM_SET} | cpio -div; \
+ ${FIND} * -type f -o -type l > ${PLIST}; \
+ ${FIND} -d * -type d | ${SED} -e 's:^:@dirrm :' >> ${PLIST}
+
+.include "../../x11-toolkits/linux-gtk/Makefile"
diff --git a/textproc/linux-expat/distinfo.i386 b/textproc/linux-expat/distinfo.i386
new file mode 100644
index 000000000000..4e62463504a5
--- /dev/null
+++ b/textproc/linux-expat/distinfo.i386
@@ -0,0 +1,2 @@
+$FreeBSD$
+MD5 (rpm/expat-1.95.5-2.i386.rpm) = 76aa046090620b8c51107a94a3e80d7c
diff --git a/textproc/linux-expat/pkg-descr b/textproc/linux-expat/pkg-descr
new file mode 100644
index 000000000000..74540c55ae58
--- /dev/null
+++ b/textproc/linux-expat/pkg-descr
@@ -0,0 +1,13 @@
+This is a Linux/i386 binary port of Expat.
+
+from the README:
+
+ This is Expat, a C library for parsing XML, written by James
+ Clark. Expat is a stream-oriented XML parser. This means
+ that you register handlers with the parser before starting
+ the parse. These handlers are called when the parser
+ discovers the associated structures in the document being
+ parsed. A start tag is an example of the kind of structures
+ for which you may register handlers.
+
+WWW: http://www.libexpat.org/