aboutsummaryrefslogtreecommitdiff
path: root/textproc/linux-libxml/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2006-05-01 17:28:17 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2006-05-01 17:28:17 +0000
commitc1eba2d83eb1b997b5906a1458529c5c6a6a2fa4 (patch)
treeae044c026c4c8ae63ae3e6cd375428c689780f05 /textproc/linux-libxml/Makefile
parent205f4f916c424ba649de05e7db3c1c34afa55d33 (diff)
- convert to use bsd.linux-rpm.mk (get rid of include of linux-gtk/Makefile) [1]
- use fixed plists [1] - category "linux" added to those ports without it [1] - update some ports to a recent FC3 one [1] - remove plists/... for Alpha (there's no support since linux_base-8 for Alpha anymore) - don't hardcode version numbers in some plists, use PLIST_SUB instead (any errors are mine, don't keep them, send them to me) Regarding linux-ungif I declare a maintainer timeout (one month, Boris tried to contact the maintainer) and also pull the "sweeping commit"-card (the port which it uses as some kind of master port can not be used for this anymore). Besides this, I don't think he will be upset when other people do the work instead of adding an entry to his TODO list. :-) This commit brings us just before the switch of the default linux base port to the fc3 one, modulo some bugs which may appear. So: Beta testers wanted! To test: sed -i.old -e 's:linux-XFree86-libs:linux-xorg-libs:' /usr/ports/Mk/bsd.port.mk echo OVERRIDE_LINUX_BASE_PORT=fc3 >> /etc/make.conf portupgrade -f -o emulators/linux_base-fc3 -f linux_base-8 portupgrade -o x11/linux-xorg-libs linux-XFree86-libs portupgrade linux-\* The first two steps are necessary to switch to fc3 as the new default linux base port, the last 3 steps to upgrade to fc3. And feel free to send a big "Thank you!" to Boris, he did a lot of the work! I just provided some hints and answered some questions (besides from committing all the necessary changes for FC3 and doing some minor changes+comments/improvements to/of his work), even when he tries to tell you something else. ;-) Submitted by: Boris Samorodov <bsam@ipt.ru> [1]
Notes
Notes: svn path=/head/; revision=161107
Diffstat (limited to 'textproc/linux-libxml/Makefile')
-rw-r--r--textproc/linux-libxml/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/textproc/linux-libxml/Makefile b/textproc/linux-libxml/Makefile
index 80f39d9b6cb5..a0406cbb878e 100644
--- a/textproc/linux-libxml/Makefile
+++ b/textproc/linux-libxml/Makefile
@@ -7,19 +7,16 @@
PORTNAME= libxml
PORTVERSION= 1.8.17
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= textproc linux
-MASTER_SITES= ${MASTER_SITE_FEDORA_LINUX}
-MASTER_SITE_SUBDIR= 3/i386/os/Fedora/RPMS 3/SRPMS
-
-.if defined(PACKAGE_BUILDING)
-SRC_DISTFILES+= libxml-${PORTVERSION}-11.src.rpm
-ALWAYS_KEEP_DISTFILES= yes
-.endif
+DISTNAME= ${PORTNAME}-${PORTVERSION}-11
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= RPM of libxml
-RPM_SET= libxml-${PORTVERSION}-11.${ARCH}.rpm
+USE_LINUX_RPM= yes
+LINUX_DIST_VER= 3
+INSTALLS_SHLIB= yes
+PLIST= pkg-plist.${LINUX_RPM_ARCH}
-.include "../../x11-toolkits/linux-gtk/Makefile"
+.include <bsd.port.mk>