aboutsummaryrefslogtreecommitdiff
path: root/textproc/linux-xerces-c2
diff options
context:
space:
mode:
authorBoris Samorodov <bsam@FreeBSD.org>2006-11-22 17:48:59 +0000
committerBoris Samorodov <bsam@FreeBSD.org>2006-11-22 17:48:59 +0000
commit2230414ef88c487c8d79f83a4dd8f437dc009e21 (patch)
treebd36e7e8353d72783e41a8b9696704a284a99107 /textproc/linux-xerces-c2
parent245d8ae18dd2fe6b98e7b4fc1d33ee5347c00a9b (diff)
downloadports-2230414ef88c487c8d79f83a4dd8f437dc009e21.tar.gz
ports-2230414ef88c487c8d79f83a4dd8f437dc009e21.zip
Notes
Diffstat (limited to 'textproc/linux-xerces-c2')
-rw-r--r--textproc/linux-xerces-c2/Makefile27
-rw-r--r--textproc/linux-xerces-c2/distinfo.i3863
-rw-r--r--textproc/linux-xerces-c2/pkg-descr7
-rw-r--r--textproc/linux-xerces-c2/pkg-plist7
4 files changed, 44 insertions, 0 deletions
diff --git a/textproc/linux-xerces-c2/Makefile b/textproc/linux-xerces-c2/Makefile
new file mode 100644
index 000000000000..43cf8b03e439
--- /dev/null
+++ b/textproc/linux-xerces-c2/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: linux-xerces-c2
+# Date created: 7 November 2006
+# Whom: Alexander Logvinov <ports@logvinov.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xerces
+PORTVERSION= 2.7.0
+CATEGORIES= textproc linux
+MASTER_SITES= http://ftp.belnet.be/packages/dries.ulyssis.org/fedora/fc4/i386/RPMS.dries/ \
+ ftp://ftp.freshrpms.net/pub/dag/dries/fedora/fc4/i386/RPMS.dries/ \
+ ftp://ftp.icm.edu.pl/vol/rzm4/linux-dag/dries/fedora/fc4/i386/RPMS.dries/
+PKGNAMESUFFIX= -c2
+DISTNAME= ${PORTNAME}-c-${PORTVERSION}-1.2.fc4.rf
+
+MAINTAINER= ports@logvinov.com
+COMMENT= Validating XML parser from the Apache XML Project (linux version)
+
+USE_LINUX_RPM= yes
+ONLY_FOR_ARCHS= i386 amd64
+LINUX_DIST_VER= 4
+INSTALLS_SHLIB= yes
+SRC_DISTFILES=
+PLIST_SUB= PORTVERSION="${PORTVERSION}"
+
+.include <bsd.port.mk>
diff --git a/textproc/linux-xerces-c2/distinfo.i386 b/textproc/linux-xerces-c2/distinfo.i386
new file mode 100644
index 000000000000..1f5fc1589784
--- /dev/null
+++ b/textproc/linux-xerces-c2/distinfo.i386
@@ -0,0 +1,3 @@
+MD5 (rpm/i386/fedora/4/xerces-c-2.7.0-1.2.fc4.rf.i386.rpm) = f5ad33166be03341c4524ae469c8da7e
+SHA256 (rpm/i386/fedora/4/xerces-c-2.7.0-1.2.fc4.rf.i386.rpm) = ca4b5cd94ac2eca8f47ae75f3b8b17bd311f3cb0a00b31bfa2c6e459af0916ab
+SIZE (rpm/i386/fedora/4/xerces-c-2.7.0-1.2.fc4.rf.i386.rpm) = 1280280
diff --git a/textproc/linux-xerces-c2/pkg-descr b/textproc/linux-xerces-c2/pkg-descr
new file mode 100644
index 000000000000..d66200586e7f
--- /dev/null
+++ b/textproc/linux-xerces-c2/pkg-descr
@@ -0,0 +1,7 @@
+Xerces-C++ is a validating XML parser from the Apache XML Project.
+It provides a shared library to parse, generate, mainpulate and
+validate XML documents from within your own application.
+
+(Linux version)
+
+WWW: http://xml.apache.org/xerces-c/
diff --git a/textproc/linux-xerces-c2/pkg-plist b/textproc/linux-xerces-c2/pkg-plist
new file mode 100644
index 000000000000..b67c78ec308e
--- /dev/null
+++ b/textproc/linux-xerces-c2/pkg-plist
@@ -0,0 +1,7 @@
+usr/lib/libxerces-c.so.27
+usr/lib/libxerces-c.so.27.0
+usr/lib/libxerces-depdom.so.27
+usr/lib/libxerces-depdom.so.27.0
+usr/share/doc/xerces-c-%%PORTVERSION%%/LICENSE.txt
+usr/share/doc/xerces-c-%%PORTVERSION%%/Readme.html
+@dirrm usr/share/doc/xerces-c-%%PORTVERSION%%