aboutsummaryrefslogtreecommitdiff
path: root/textproc/luaexpat/Makefile
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-14 06:02:55 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2009-07-14 06:02:55 +0000
commite271fb5d9f94d1c04e6faa02cfc5e67b65b32a7e (patch)
treeaf914d8b3b968359dc31ec93e9c8d12d1830f11d /textproc/luaexpat/Makefile
parent37715c63a8ba4dbe9f389453e4bb43675aeb0dcf (diff)
Notes
Diffstat (limited to 'textproc/luaexpat/Makefile')
-rw-r--r--textproc/luaexpat/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/luaexpat/Makefile b/textproc/luaexpat/Makefile
new file mode 100644
index 000000000000..75b7c427624d
--- /dev/null
+++ b/textproc/luaexpat/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: luaexpat
+# Date created: 25 June 2009
+# Whom: Andrew Lewis <dru@silenceisdefeat.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= luaexpat
+PORTVERSION= 1.1
+CATEGORIES= textproc
+MASTER_SITES= http://luaforge.net/frs/download.php/2469/
+PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
+
+MAINTAINER= dru@silenceisdefeat.net
+COMMENT= LuaExpat is a SAX XML parser based on the Expat library
+
+LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
+
+ONLY_FOR_ARCHS= i386
+
+MAKEFILE= makefile
+ALL_TARGET= lib
+USE_LUA= 5.0-5.1
+WANT_LUA_VER= 5.1
+
+CFLAGS+= -fPIC
+
+.if ${USE_LUA} == 5.0
+BUILD_DEPENDS+= ${NONEXISTENT}:${PORTSDIR}/devel/lua50-compat51:build
+.endif
+
+.include <bsd.port.mk>