aboutsummaryrefslogtreecommitdiff
path: root/textproc/markdown
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2005-10-13 13:41:50 +0000
committerAnton Berezin <tobez@FreeBSD.org>2005-10-13 13:41:50 +0000
commit4d5e81b1c4a0bbcd0509845eded6acb94b5eba43 (patch)
tree8ebee1687d9998f8b84dc0b1ad4e4b9125cae06e /textproc/markdown
parent6d6f8fbed6c699bb0e86a2851a207717f6db853d (diff)
downloadports-4d5e81b1c4a0bbcd0509845eded6acb94b5eba43.tar.gz
ports-4d5e81b1c4a0bbcd0509845eded6acb94b5eba43.zip
Notes
Diffstat (limited to 'textproc/markdown')
-rw-r--r--textproc/markdown/Makefile45
-rw-r--r--textproc/markdown/distinfo2
-rw-r--r--textproc/markdown/pkg-descr9
-rw-r--r--textproc/markdown/pkg-plist1
4 files changed, 57 insertions, 0 deletions
diff --git a/textproc/markdown/Makefile b/textproc/markdown/Makefile
new file mode 100644
index 000000000000..073143675712
--- /dev/null
+++ b/textproc/markdown/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: Markdown
+# Date created: 13 October 2005
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= markdown
+PORTVERSION= 1.0.1
+CATEGORIES= textproc perl5
+MASTER_SITES= http://daringfireball.net/projects/downloads/
+DISTNAME= Markdown_${PORTVERSION}
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= A text-to-HTML conversion tool for web writers
+
+BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_ZIP= yes
+USE_PERL5= yes
+NO_BUILD= yes
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= License.text Markdown-Readme.text
+.endif
+
+post-patch:
+ ${PERL} -pi -e "s#/usr/bin/perl#${PERL}#" ${WRKSRC}/Markdown.pl
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/Markdown.pl ${PREFIX}/bin/markdown
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} "${WRKSRC}/License.text" ${DOCSDIR}/License.text
+ ${INSTALL_DATA} "${WRKSRC}/Markdown Readme.text" ${DOCSDIR}/Markdown-Readme.text
+.endif
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= Port requires perl 5.6.0 or later. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/markdown/distinfo b/textproc/markdown/distinfo
new file mode 100644
index 000000000000..2ad8f5eeaf07
--- /dev/null
+++ b/textproc/markdown/distinfo
@@ -0,0 +1,2 @@
+MD5 (Markdown_1.0.1.zip) = 83d1722ad51c11e8330c01a4af285f9c
+SIZE (Markdown_1.0.1.zip) = 18647
diff --git a/textproc/markdown/pkg-descr b/textproc/markdown/pkg-descr
new file mode 100644
index 000000000000..c807485b63d5
--- /dev/null
+++ b/textproc/markdown/pkg-descr
@@ -0,0 +1,9 @@
+Markdown is a text-to-HTML conversion tool for web writers. Markdown
+allows you to write using an easy-to-read, easy-to-write plain text
+format, then convert it to structurally valid XHTML (or HTML).
+
+Thus, "Markdown" is two things: a plain text markup syntax, and a
+software tool, written in Perl, that converts the plain text markup to
+HTML.
+
+WWW: http://daringfireball.net/projects/markdown/
diff --git a/textproc/markdown/pkg-plist b/textproc/markdown/pkg-plist
new file mode 100644
index 000000000000..cde96a02fbe0
--- /dev/null
+++ b/textproc/markdown/pkg-plist
@@ -0,0 +1 @@
+bin/markdown