aboutsummaryrefslogtreecommitdiff
path: root/textproc/minidom/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-13 17:18:46 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2001-08-13 17:18:46 +0000
commit984f0e2327a3ff82ad2be8ce50070ebe252ec94b (patch)
treec7c102a23c45f2f5668a090866430b2790806d33 /textproc/minidom/Makefile
parentc4503c58a617ac4ad60ac9f8b26ff1f67ad381cb (diff)
downloadports-984f0e2327a3ff82ad2be8ce50070ebe252ec94b.tar.gz
ports-984f0e2327a3ff82ad2be8ce50070ebe252ec94b.zip
Notes
Diffstat (limited to 'textproc/minidom/Makefile')
-rw-r--r--textproc/minidom/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/textproc/minidom/Makefile b/textproc/minidom/Makefile
new file mode 100644
index 000000000000..16079478ec83
--- /dev/null
+++ b/textproc/minidom/Makefile
@@ -0,0 +1,32 @@
+# ex:ts=8
+# New ports collection makefile for: minidom
+# Date created: Aug 13, 2001
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= minidom
+PORTVERSION= 0.1.2
+CATEGORIES= textproc
+MASTER_SITES= http://www.cs.unibo.it/helm/mml-widget/sources/
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
+ giconv:${PORTSDIR}/converters/libiconv
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+USE_GLIB= yes
+USE_LIBTOOL= yes
+USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${PERL} -pi -e "s,-lglib,-lglib12,g ; \
+ s,glib-config,${GLIB_CONFIG},g" ${WRKSRC}/configure.in
+
+.include <bsd.port.mk>