aboutsummaryrefslogtreecommitdiff
path: root/textproc/modlogan/Makefile
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2014-06-03 20:04:00 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2014-06-03 20:04:00 +0000
commit266ac37f7708aaf19c283f393d8a8ea0ae8602b3 (patch)
tree0ab34acbd5282a1f81c4f042d4d6cfd103b71636 /textproc/modlogan/Makefile
parentfb8fa75b9018c7b795d017815247b49bc95ad1a5 (diff)
downloadports-266ac37f7708aaf19c283f393d8a8ea0ae8602b3.tar.gz
ports-266ac37f7708aaf19c283f393d8a8ea0ae8602b3.zip
Notes
Diffstat (limited to 'textproc/modlogan/Makefile')
-rw-r--r--textproc/modlogan/Makefile24
1 files changed, 9 insertions, 15 deletions
diff --git a/textproc/modlogan/Makefile b/textproc/modlogan/Makefile
index e69f982c551d..197508561849 100644
--- a/textproc/modlogan/Makefile
+++ b/textproc/modlogan/Makefile
@@ -10,13 +10,12 @@ MASTER_SITES= http://www.mirrorservice.org/sites/www.ibiblio.org/gentoo/distfile
MAINTAINER= netchild@FreeBSD.org
COMMENT= A modular log file analysis program
-LIB_DEPENDS= adns:${PORTSDIR}/dns/adns \
- gd:${PORTSDIR}/graphics/gd \
- pcre:${PORTSDIR}/devel/pcre \
- expat:${PORTSDIR}/textproc/expat2
+LIB_DEPENDS= libadns.so:${PORTSDIR}/dns/adns \
+ libgd.so:${PORTSDIR}/graphics/gd \
+ libpcre.so:${PORTSDIR}/devel/pcre \
+ libexpat.so:${PORTSDIR}/textproc/expat2
-USE_AUTOTOOLS= libtool
-USES= gettext
+USES= gettext libtool:keepla
# Please don't remove the comments, as soon as autoconf/libtool get's
# updated in the ports collection the comments may be removed.
@@ -31,11 +30,9 @@ CONFIGURE_ARGS+=--with-mysql
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-MAN1= modlogan.1
DOC1= faq.txt glosar manual.txt translations.txt \
using-plugins.txt writing-plugins.txt
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's:\@config_path\@:${PREFIX}/etc/modlogan:g' ${WRKSRC}/doc/modlogan.conf-dist.in
@@ -44,17 +41,14 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
- ${MKDIR} ${PREFIX}/share/doc/modlogan
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/share/doc/modlogan
.for i in ${DOC1}
- @${INSTALL_DATA} ${WRKSRC}/doc/${i} ${PREFIX}/share/doc/modlogan/${i}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${i} ${STAGEDIR}/${PREFIX}/share/doc/modlogan/${i}
.endfor
.endif
- ${MKDIR} ${PREFIX}/share/examples/modlogan
+ ${MKDIR} ${STAGEDIR}/${PREFIX}/share/examples/modlogan
.for i in footer.ihtml header.ihtml output.tmpl convert_history_to_07x.pl convert_to_055.pl convert_to_060.pl
- @${INSTALL_DATA} ${WRKSRC}/doc/${i} ${PREFIX}/share/examples/modlogan/${i}
-.endfor
-.for i in css conf def.conf
- [ -f ${PREFIX}/etc/modlogan/modlogan.${i} ] || ${INSTALL_DATA} ${PREFIX}/etc/modlogan/modlogan.${i}-dist ${PREFIX}/etc/modlogan/modlogan.${i}
+ @${INSTALL_DATA} ${WRKSRC}/doc/${i} ${STAGEDIR}/${PREFIX}/share/examples/modlogan/${i}
.endfor
.include <bsd.port.mk>