aboutsummaryrefslogtreecommitdiff
path: root/textproc/multimarkdown
diff options
context:
space:
mode:
authorAdam Weinberger <adamw@FreeBSD.org>2011-10-27 22:18:55 +0000
committerAdam Weinberger <adamw@FreeBSD.org>2011-10-27 22:18:55 +0000
commit9e57be564d305d1e69506c4a5c666a0b2a58da20 (patch)
tree89ecaf5b149d557346da8ac952e19e8ede7bf956 /textproc/multimarkdown
parent3d0b0e5dc2c7597c5f3dedfefed6e71e0ccaa816 (diff)
Notes
Diffstat (limited to 'textproc/multimarkdown')
-rw-r--r--textproc/multimarkdown/Makefile42
-rw-r--r--textproc/multimarkdown/distinfo2
-rw-r--r--textproc/multimarkdown/pkg-descr24
3 files changed, 68 insertions, 0 deletions
diff --git a/textproc/multimarkdown/Makefile b/textproc/multimarkdown/Makefile
new file mode 100644
index 000000000000..bbd23730064d
--- /dev/null
+++ b/textproc/multimarkdown/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: multimarkdown
+# Date created: 27 October 2011
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= multimarkdown
+PORTVERSION= 3.2
+CATEGORIES= textproc
+MASTER_SITES= https://github.com/${GH_DEVELOPER}/${GH_PORTNAME}/tarball/${DISTVERSION}/
+DISTNAME= ${GH_DEVELOPER}-${GH_PORTNAME}-${DISTVERSION}-0-g${GH_VERSION}
+
+MAINTAINER= adamw@FreeBSD.org
+COMMENT= Extended Markdown processor with more features, written in C
+
+LICENSE= MIT
+
+# Github makes this very confusing
+GH_PORTNAME= peg-${PORTNAME}
+GH_DEVELOPER= fletcher #GH trees live under a username
+GH_VERSION= fbe21522ca #GH appends a commit hash to the filename
+GH_SRCDIR= 7aacba2 #GH appends something else (??) to the extracted pathname
+WRKSRC= ${WRKDIR}/${GH_DEVELOPER}-${GH_PORTNAME}-${GH_SRCDIR}
+FETCH_ARGS= -prR #GH issues HTTP/302 errors for source tarballs
+
+USE_GMAKE= yes
+ALL_TARGET= ALL
+MAKE_JOBS_UNSAFE= yes
+
+PLIST_FILES= bin/multimarkdown bin/mmd bin/mmd2all bin/mmd2odf bin/mmd2opml bin/mmd2pdf bin/mmd2tex
+PORTDOCS= LICENSE README.markdown
+
+do-install:
+ @${INSTALL} -m 755 ${WRKSRC}/multimarkdown ${PREFIX}/bin
+ @${INSTALL} -m 755 ${WRKSRC}/scripts/* ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @(cd ${WRKSRC}; ${INSTALL} -m 644 LICENSE README.markdown ${DOCSDIR})
+.endif
+
+.include <bsd.port.mk>
diff --git a/textproc/multimarkdown/distinfo b/textproc/multimarkdown/distinfo
new file mode 100644
index 000000000000..317780aafd60
--- /dev/null
+++ b/textproc/multimarkdown/distinfo
@@ -0,0 +1,2 @@
+SHA256 (fletcher-peg-multimarkdown-3.2-0-gfbe21522ca.tar.gz) = 21f570ff835db9034ab65594fab4fadf8ddb8977cd76d6785e9a48c0210edacd
+SIZE (fletcher-peg-multimarkdown-3.2-0-gfbe21522ca.tar.gz) = 116966
diff --git a/textproc/multimarkdown/pkg-descr b/textproc/multimarkdown/pkg-descr
new file mode 100644
index 000000000000..6860d1da6898
--- /dev/null
+++ b/textproc/multimarkdown/pkg-descr
@@ -0,0 +1,24 @@
+MultiMarkdown, or MMD, is a tool to help turn minimally marked-up plain
+text into well formatted documents, including HTML, PDF (by way of
+LaTeX), OPML, or OpenDocument (specifically, Flat OpenDocument or
+'.fodt', which can in turn be converted into RTF, Microsoft Word, or
+virtually any other word-processing format).
+
+MMD is a superset of the Markdown syntax, originally created by John
+Gruber. It adds multiple syntax features (tables, footnotes, and
+citations, to name a few), in addition to the various output formats
+listed above (Markdown only creates HTML). Additionally, it builds in
+'smart' typography for various languages (proper left- and right-sided
+quotes, for example).
+
+MultiMarkdown was originally a fork of the Markdown Perl code, but as of
+version 3.0 has been rewritten as a fork of peg-markdown by John
+MacFarlane, written in C. It can be compiled for any major operating
+system, and as a native binary runs much faster than the Perl version it
+replaces.
+
+
+NOTE: To use the mmd2pdf script, you must install print/latexmk.
+
+
+WWW: http://www.fletcherpenney.net/multimarkdown/