aboutsummaryrefslogtreecommitdiff
path: root/textproc/muse/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-16 11:04:55 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-16 11:04:55 +0000
commit4513766db93bdbd28afa9f19ff9b22597813986e (patch)
treea7c1eaf52f9f580ce4bc85d9c44ea78693e12e31 /textproc/muse/Makefile
parent2955cb21eaff5b7f6e753cbdbc1e97576c663ec3 (diff)
downloadports-4513766db93bdbd28afa9f19ff9b22597813986e.tar.gz
ports-4513766db93bdbd28afa9f19ff9b22597813986e.zip
Notes
Diffstat (limited to 'textproc/muse/Makefile')
-rw-r--r--textproc/muse/Makefile56
1 files changed, 56 insertions, 0 deletions
diff --git a/textproc/muse/Makefile b/textproc/muse/Makefile
new file mode 100644
index 000000000000..188601780e74
--- /dev/null
+++ b/textproc/muse/Makefile
@@ -0,0 +1,56 @@
+# New ports collection makefile for: muse
+# Date created: February 22 2006
+# Whom: Dryice Liu <dryice@dryice.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= muse
+PORTVERSION= 3.02.6
+CATEGORIES= textproc elisp
+MASTER_SITES= http://download.gna.org/muse-el/ \
+ http://dryice.name/computer/FreeBSD/distfiles/
+PKGNAMESUFFIX= -${EMACS_PORT_NAME}
+
+MAINTAINER= dryice@dryice.name
+COMMENT= An authoring and publishing environment for Emacs
+
+USE_EMACS= yes
+USE_GMAKE= yes
+EMACS_PORT_NAME?= emacs21
+
+.if ${EMACS_PORT_NAME} != "emacs21"
+PORTNAMESUFFIX= ${PKGNAMESUFFIX}
+.endif
+
+LISPDIR= ${PREFIX}/${EMACS_SITE_LISPDIR}/${PORTNAME}
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= AUTHORS ChangeLog ChangeLog.2004 ChangeLog.main NEWS \
+ README scripts
+.endif
+
+post-install:
+ ${MKDIR} ${LISPDIR}/contrib
+.for i in *
+ ${CP} -R ${WRKSRC}/contrib/${i} ${LISPDIR}/contrib
+.endfor
+
+ ${MKDIR} ${LISPDIR}/experimental
+.for i in *
+ ${INSTALL_DATA} ${WRKSRC}/experimental/${i} ${LISPDIR}/experimental
+.endfor
+
+ ${MKDIR} ${EXAMPLESDIR}
+.for i in *
+ ${CP} -R ${WRKSRC}/examples/${i} ${EXAMPLESDIR}
+.endfor
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${CP} -R ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>