aboutsummaryrefslogtreecommitdiff
path: root/textproc/nfbtrans/Makefile
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1998-08-30 02:32:23 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1998-08-30 02:32:23 +0000
commitebf88ffc8a528bbfa293ed03deeac5b1d4882efe (patch)
tree60ce9d0cb47baa67e7bb6acb6c34fc65815f263e /textproc/nfbtrans/Makefile
parent0575e236a2a984391d602481b7eb648bc677b2fd (diff)
Notes
Diffstat (limited to 'textproc/nfbtrans/Makefile')
-rw-r--r--textproc/nfbtrans/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/textproc/nfbtrans/Makefile b/textproc/nfbtrans/Makefile
new file mode 100644
index 000000000000..9d9e14345020
--- /dev/null
+++ b/textproc/nfbtrans/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: nfbtrans
+# Version required: 7.50.2
+# Date created: 30 Aug 1998
+# Whom: Masafumi NAKANE <max@FreeBSD.ORG>
+#
+# $Id: porting.sgml,v 1.16 1996/03/21 14:15:01 asami Exp $
+#
+
+DISTNAME= nfbtr750
+PKGNAME= nfbtrans-7.50.2
+CATEGORIES= textproc
+MASTER_SITES= ftp://ftp.netcom.com/pub/in/inge/
+EXTRACT_SUFX= .zip
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} nfb7502.zip
+
+MAINTAINER= max@FreeBSD.ORG
+
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+RESTRICTED= "Unclear copyright status"
+EXTRACT_CMD= unzip
+EXTRACT_ARGS= -q -a -L -o
+NO_WRKSUBDIR= yes
+ALL_TARGET= freebsd
+MAKEFILE= makefile
+
+do-install:
+ ${MKDIR} ${PREFIX}/lib/nfbtrans/tables
+ ${INSTALL_PROGRAM} ${WRKSRC}/nfbtrans ${PREFIX}/bin
+.for f in braille.tab back.tab english.dic nfbtrans.cnf
+ ${INSTALL_DATA} ${WRKSRC}/$f ${PREFIX}/lib/nfbtrans
+.endfor
+ @unzip -q -L -a -o ${WRKSRC}/tables.zip -d ${PREFIX}/lib/nfbtrans/tables
+.if !defined(NOPORTDOCS)
+ @${ECHO} '~0 ~-pw=80 ~-ls=99 ~-pl=56 ~-if=12 ~-fc=. ~o5 ~p- ~-ip=0 ~-oc=1' \
+ | ${CAT} - ${WRKSRC}/nfbtrans.fmt > ${WRKSRC}/nfbprint.fmt
+ @${WRKSRC}/nfbtrans st=${WRKSRC}/stat.txt qm=1 ob=oc=15 \
+ ${WRKSRC}/nfbprint.fmt > ${WRKSRC}/nfbtrans.doc
+ ${MKDIR} ${PREFIX}/share/doc/nfbtrans
+ ${INSTALL_DATA} ${WRKSRC}/nfbtrans.doc ${PREFIX}/share/doc/nfbtrans
+ ${INSTALL_DATA} ${WRKSRC}/nfbtrans.fmt ${PREFIX}/share/doc/nfbtrans
+.endif
+
+.include <bsd.port.mk>