aboutsummaryrefslogtreecommitdiff
path: root/textproc/nux
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-11-24 15:19:45 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-11-24 15:19:45 +0000
commitb466ca9e14002d63e3c33bf619251c1e6c093edb (patch)
tree71aec454b7e5a17d493115d035ed0e67aef4ce18 /textproc/nux
parent8781ff522a4a9d1f6425d638d145ecf8f9bf4236 (diff)
downloadports-b466ca9e14002d63e3c33bf619251c1e6c093edb.tar.gz
ports-b466ca9e14002d63e3c33bf619251c1e6c093edb.zip
Notes
Diffstat (limited to 'textproc/nux')
-rw-r--r--textproc/nux/Makefile25
-rw-r--r--textproc/nux/distinfo5
-rw-r--r--textproc/nux/files/fire-validate.sh.in5
-rw-r--r--textproc/nux/files/fire-xquery.sh.in5
4 files changed, 20 insertions, 20 deletions
diff --git a/textproc/nux/Makefile b/textproc/nux/Makefile
index 0128ca297033..dff0f9d8c4bc 100644
--- a/textproc/nux/Makefile
+++ b/textproc/nux/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= nux
-PORTVERSION= 1.0
+PORTVERSION= 1.3
PORTEPOCH= 1
CATEGORIES= textproc java
MASTER_SITES= http://dsd.lbl.gov/nux-download/releases/
@@ -17,7 +17,7 @@ COMMENT= Small open-source XQuery extension of the XOM library
RUN_DEPENDS= ${JAVALIBDIR}/xom.jar:${PORTSDIR}/textproc/xom \
${JAVALIBDIR}/saxon8.jar:${PORTSDIR}/textproc/saxon-devel
-OPTIONS= VALIDATION_TOOL "Install the XML Schema validation tool" on
+OPTIONS= XQUERY_TOOL "Install the XQuery command-line tool" on
USE_JAVA= yes
JAVA_VERSION= 1.4+
@@ -26,14 +26,14 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
.include <bsd.port.pre.mk>
-.if defined(WITH_VALIDATION_TOOL)
+.if defined(WITH_XQUERY_TOOL)
RUN_DEPENDS+= ${JAVALIBDIR}/getopt.jar:${PORTSDIR}/java/java-getopt \
classpath:${PORTSDIR}/java/javavmwrapper
.endif
PLIST_FILES= %%JAVAJARDIR%%/${PORTNAME}.jar
-.if defined(WITH_VALIDATION_TOOL)
-PLIST_FILES+= bin/fire-validate
+.if defined(WITH_XQUERY_TOOL)
+PLIST_FILES+= bin/fire-xquery
.endif
.if !defined(NOPORTDOCS)
PORTDOCS= api changelog.html cvs.html dependencies.html \
@@ -41,8 +41,8 @@ PORTDOCS= api changelog.html cvs.html dependencies.html \
mailing.html readme.html style.css todo.html
.endif
-.if defined(WITH_VALIDATION_TOOL)
-SUB_FILES= fire-validate.sh
+.if defined(WITH_XQUERY_TOOL)
+SUB_FILES= fire-xquery.sh
.endif
do-install:
@@ -50,16 +50,15 @@ do-install:
@${MKDIR} ${JAVAJARDIR}
@${INSTALL_DATA} ${WRKSRC}/lib/${PORTNAME}.jar ${JAVAJARDIR}/
@${ECHO_MSG} " [ DONE ]"
-.if defined(WITH_VALIDATION_TOOL)
- @${ECHO_MSG} -n ">> Installing validation tool as ${PREFIX}/bin/${VALIDATION_TOOL}..."
- @${INSTALL_SCRIPT} ${WRKDIR}/fire-validate.sh ${PREFIX}/bin/fire-validate
+.if defined(WITH_XQUERY_TOOL)
+ @${ECHO_MSG} -n ">> Installing XQuery command-line tool as ${PREFIX}/bin/fire-xquery..."
+ @${INSTALL_SCRIPT} ${WRKDIR}/fire-xquery.sh ${PREFIX}/bin/fire-xquery
@${ECHO_MSG} " [ DONE ]"
.endif
.if !defined(NOPORTDOCS)
@${ECHO_MSG} -n ">> Installing documentation in ${DOCSDIR}..."
- @${MKDIR} ${DOCSDIR}
- @cd ${WRKSRC}/doc/ && ${FIND} ${PORTDOCS} \
- | ${CPIO} -pdmu -R ${SHAREOWN}:${SHAREGRP} ${DOCSDIR} > /dev/null 2>&1
+ @cd ${WRKSRC}/doc/ && ${FIND} ${PORTDOCS} -type d -exec ${MKDIR} ${DOCSDIR}/{} \;
+ @cd ${WRKSRC}/doc/ && ${FIND} ${PORTDOCS} -type f -exec ${INSTALL_DATA} {} ${DOCSDIR}/{} \;
@${ECHO_MSG} " [ DONE ]"
.endif
diff --git a/textproc/nux/distinfo b/textproc/nux/distinfo
index d7999e3bed1d..61f08b909964 100644
--- a/textproc/nux/distinfo
+++ b/textproc/nux/distinfo
@@ -1,2 +1,3 @@
-MD5 (nux-1.0.tar.gz) = 63568d0927efa051eee4bcb442c19c2c
-SIZE (nux-1.0.tar.gz) = 3523718
+MD5 (nux-1.3.tar.gz) = 1639cdfe577314a62ed178ecc3a6ca16
+SHA256 (nux-1.3.tar.gz) = c9eb5782fc46275aa940f3bb799ae93ade6efb952f5ecc5c9a07cd687faf9037
+SIZE (nux-1.3.tar.gz) = 7880933
diff --git a/textproc/nux/files/fire-validate.sh.in b/textproc/nux/files/fire-validate.sh.in
deleted file mode 100644
index 29828649f3c3..000000000000
--- a/textproc/nux/files/fire-validate.sh.in
+++ /dev/null
@@ -1,5 +0,0 @@
-#!/bin/sh
-#
-# $FreeBSD$
-
-JAVA_VERSION="1.4+" "%%LOCALBASE%%/bin/java" -classpath "`%%LOCALBASE%%/bin/classpath`" nux.xom.tests.ValidationCommand "$@"
diff --git a/textproc/nux/files/fire-xquery.sh.in b/textproc/nux/files/fire-xquery.sh.in
new file mode 100644
index 000000000000..e996b16b64ce
--- /dev/null
+++ b/textproc/nux/files/fire-xquery.sh.in
@@ -0,0 +1,5 @@
+#!/bin/sh
+#
+# $FreeBSD$
+
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -classpath "`%%LOCALBASE%%/bin/classpath`" nux.xom.tests.XQueryCommand "$@"