aboutsummaryrefslogtreecommitdiff
path: root/textproc/openfts/Makefile
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>2004-02-16 14:31:03 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>2004-02-16 14:31:03 +0000
commit016527aee7bf36f7b0e2967f342869d93a463fc5 (patch)
treebc6b602c0c39d97efbd2299b145768b92055c2f9 /textproc/openfts/Makefile
parent9ac659e93887a76204af09fec851ddc5f4048dba (diff)
Notes
Diffstat (limited to 'textproc/openfts/Makefile')
-rw-r--r--textproc/openfts/Makefile24
1 files changed, 1 insertions, 23 deletions
diff --git a/textproc/openfts/Makefile b/textproc/openfts/Makefile
index eb113176ae52..9a3df8bd5d01 100644
--- a/textproc/openfts/Makefile
+++ b/textproc/openfts/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= openfts
-PORTVERSION= 0.34
-PORTREVISION= 2
+PORTVERSION= 0.36
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= openfts
@@ -16,12 +15,6 @@ DISTNAME= Search-OpenFTS-${PORTVERSION}
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Open Source Full Text Search engine
-EXTRACT_DEPENDS=/nonexistent:${PORTSDIR}/databases/postgresql7:configure
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-Pg
-
-BROKEN= "Inconsistent dependencies (mysql-client 3.x and 4.x)"
-DEPRECATED= "This port will be removed on April 15 if still broken."
-
PERL_CONFIGURE= yes
USE_REINPLACE= yes
@@ -30,21 +23,6 @@ MAN3= Search::OpenFTS.3 Search::OpenFTS::Base.3 \
Search::OpenFTS::Dict::UnknownDict.3 Search::OpenFTS::Index.3 \
Search::OpenFTS::Morph::ISpell.3 Search::OpenFTS::Parser.3
-PGSRC= `cd ${PORTSDIR}/databases/postgresql7; ${MAKE} -VWRKSRC`/contrib
-PGMAKE= ${GMAKE} docdir=${PREFIX}/share/doc
-
-post-extract:
- cd ${WRKSRC} && ${CP} -r pgsql_contrib_openfts ${PGSRC}/
-
-post-build:
- cd ${PGSRC}/tsearch && ${GMAKE} && \
- ${REINPLACE_CMD} 's,$$libdir,${PREFIX}/lib/postgresql,' tsearch.sql
- cd ${PGSRC}/pgsql_contrib_openfts && ${GMAKE}
-
-post-install:
- cd ${PGSRC}/tsearch && ${PGMAKE} install
- cd ${PGSRC}/pgsql_contrib_openfts && ${PGMAKE} install
-
# Sample DB initialization.
DBNAME?= openfts
create-database: