aboutsummaryrefslogtreecommitdiff
path: root/textproc/opensched
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2002-10-19 22:29:07 +0000
committerKris Kennaway <kris@FreeBSD.org>2002-10-19 22:29:07 +0000
commit30656082918742a1ceec3175bf8e11aab5b0570d (patch)
tree4c3b9358d61b44b9fef44a637da2c8a77af4bbae /textproc/opensched
parent6aee96b6e7235f17ed27655d80d1f67ed718397c (diff)
downloadports-30656082918742a1ceec3175bf8e11aab5b0570d.tar.gz
ports-30656082918742a1ceec3175bf8e11aab5b0570d.zip
Notes
Diffstat (limited to 'textproc/opensched')
-rw-r--r--textproc/opensched/Makefile1
-rw-r--r--textproc/opensched/files/patch-af11
-rw-r--r--textproc/opensched/files/patch-ag10
3 files changed, 22 insertions, 0 deletions
diff --git a/textproc/opensched/Makefile b/textproc/opensched/Makefile
index cc668f60f253..3a8998e9932d 100644
--- a/textproc/opensched/Makefile
+++ b/textproc/opensched/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opensched
PORTVERSION= 0.1.0
+PORTREVISION= 1
CATEGORIES= textproc
MASTER_SITES= http://www.m-tech.ab.ca/download/sched/
DISTNAME= ${PORTNAME}-${PORTVERSION}
diff --git a/textproc/opensched/files/patch-af b/textproc/opensched/files/patch-af
new file mode 100644
index 000000000000..66eff41cd374
--- /dev/null
+++ b/textproc/opensched/files/patch-af
@@ -0,0 +1,11 @@
+--- src/Makefile.orig Tue Oct 26 01:41:45 1999
++++ src/Makefile Sat Oct 19 15:13:56 2002
+@@ -1,6 +1,6 @@
+-CFLAGS=-Wall -g
++CFLAGS+=-Wall -g
+ LIBS=-lm
+-CC=gcc
++CC?=cc
+ CDEPEND = $(CC) -M
+ CDEPENDFLAGS =
+
diff --git a/textproc/opensched/files/patch-ag b/textproc/opensched/files/patch-ag
new file mode 100644
index 000000000000..da635f22e5fc
--- /dev/null
+++ b/textproc/opensched/files/patch-ag
@@ -0,0 +1,10 @@
+--- src/loadfile.c.orig Sat Oct 19 15:29:13 2002
++++ src/loadfile.c Sat Oct 19 15:28:40 2002
+@@ -268,6 +268,7 @@
+ t = (TASK*)malloc(sizeof(TASK));
+ if ( t == NULL )
+ Error("Can't malloc task in AddTask()");
++ memset(t, 0, sizeof(TASK));
+
+ t->id = strdup(id);
+ t->name = strdup(name);