aboutsummaryrefslogtreecommitdiff
path: root/textproc/orchard-c
diff options
context:
space:
mode:
authorPete Fritchman <petef@FreeBSD.org>2001-11-30 04:50:49 +0000
committerPete Fritchman <petef@FreeBSD.org>2001-11-30 04:50:49 +0000
commit4668be7e4e865c4172c94db86ec54126a7210dcf (patch)
tree11f16d70ef9e02c0f4c46e2b9398b1de65d6e50d /textproc/orchard-c
parent682a27239704161af3c9839271252b571d4f1350 (diff)
downloadports-4668be7e4e865c4172c94db86ec54126a7210dcf.tar.gz
ports-4668be7e4e865c4172c94db86ec54126a7210dcf.zip
Notes
Diffstat (limited to 'textproc/orchard-c')
-rw-r--r--textproc/orchard-c/Makefile36
-rw-r--r--textproc/orchard-c/distinfo1
-rw-r--r--textproc/orchard-c/pkg-comment1
-rw-r--r--textproc/orchard-c/pkg-descr8
-rw-r--r--textproc/orchard-c/pkg-plist6
5 files changed, 52 insertions, 0 deletions
diff --git a/textproc/orchard-c/Makefile b/textproc/orchard-c/Makefile
new file mode 100644
index 000000000000..f54ac9cdffe7
--- /dev/null
+++ b/textproc/orchard-c/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: orchard
+# Date created: 08 Feb 2001
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= orchard-c
+PORTVERSION= 0.5.1
+CATEGORIES= textproc
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= orchard
+DISTNAME= Orchard-C-${PORTVERSION}
+
+MAINTAINER= skv@protey.ru
+
+LIB_DEPENDS= expat.2:${PORTSDIR}/textproc/expat2 \
+ gc:${PORTSDIR}/devel/boehm-gc
+
+USE_AUTOCONF= yes
+USE_LIBTOOL= yes
+USE_PYTHON= yes
+USE_QT_VER= 2
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+
+MAKE_ENV+= RM="${RM} -f"
+INSTALLS_SHLIB= yes
+
+post-patch:
+ @${PERL} -pi -e 's,CFLAGS = -I. -g -O2,CFLAGS = -I. \@CFLAGS\@,' \
+ ${WRKSRC}/Makefile.in
+ @${PERL} -pi -e 's,^#!/usr/bin/env python,#!${PYTHON_CMD},' \
+ ${WRKSRC}/moc.py
+
+.include <bsd.port.mk>
diff --git a/textproc/orchard-c/distinfo b/textproc/orchard-c/distinfo
new file mode 100644
index 000000000000..9f1e4d8f1d85
--- /dev/null
+++ b/textproc/orchard-c/distinfo
@@ -0,0 +1 @@
+MD5 (Orchard-C-0.5.1.tar.gz) = c9b1d61090d1b20e122063e509d57c65
diff --git a/textproc/orchard-c/pkg-comment b/textproc/orchard-c/pkg-comment
new file mode 100644
index 000000000000..72da51b35891
--- /dev/null
+++ b/textproc/orchard-c/pkg-comment
@@ -0,0 +1 @@
+Innovative, lightweight API for event stream and tree views of XML
diff --git a/textproc/orchard-c/pkg-descr b/textproc/orchard-c/pkg-descr
new file mode 100644
index 000000000000..9c376c7528a3
--- /dev/null
+++ b/textproc/orchard-c/pkg-descr
@@ -0,0 +1,8 @@
+Orchard is an innovative, lightweight API for event stream and tree
+views of XML and data represented in XML. Orchard merges the best
+parts of SAX and DOM while greatly simplifying both at the same time.
+
+WWW: http://beauvoir.phil.unc.edu/groves
+
+-- Sergey Skvortsov
+skv@protey.ru
diff --git a/textproc/orchard-c/pkg-plist b/textproc/orchard-c/pkg-plist
new file mode 100644
index 000000000000..56a5baefe2fd
--- /dev/null
+++ b/textproc/orchard-c/pkg-plist
@@ -0,0 +1,6 @@
+include/moc.h
+include/moc_cexcept.h
+include/moc_generated.h
+lib/liborchard.a
+lib/liborchard.so
+lib/liborchard.so.0