aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-BibTeX-Parser/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2011-03-16 02:10:51 +0000
committerWen Heping <wen@FreeBSD.org>2011-03-16 02:10:51 +0000
commitf2be525a12e612be7c10bf358f7128799f808747 (patch)
treeea51fe5da60e44e9e4ce31448897ee88d209c2fc /textproc/p5-BibTeX-Parser/Makefile
parentcfc0adb6dee0c07ca204acdd8e4b5b789a845e6d (diff)
BibTeX::Parser is a pure perl BibTeX parser.
Notes
Notes: svn path=/head/; revision=270994
Diffstat (limited to 'textproc/p5-BibTeX-Parser/Makefile')
-rw-r--r--textproc/p5-BibTeX-Parser/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/textproc/p5-BibTeX-Parser/Makefile b/textproc/p5-BibTeX-Parser/Makefile
new file mode 100644
index 000000000000..a6f1786e3614
--- /dev/null
+++ b/textproc/p5-BibTeX-Parser/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-BibTeX-Parser
+# Date created: March 16, 2011
+# Whom: Wen Heping<wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= BibTeX-Parser
+PORTVERSION= 0.63
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= CPAN:GERHARD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= A pure perl BibTeX parser
+
+RUN_DEPENDS= p5-LaTeX-ToUnicode>=0.02:${PORTSDIR}/textproc/p5-LaTeX-ToUnicode \
+ p5-IO-String>0:${PORTSDIR}/devel/p5-IO-String
+
+PERL_CONFIGURE= yes
+
+MAN3= BibTeX::Parser.3 \
+ BibTeX::Parser::Entry.3 \
+ BibTeX::Parser::Author.3
+
+.include <bsd.port.mk>