aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-CSS-Compressor
diff options
context:
space:
mode:
authorAndrej Zverev <az@FreeBSD.org>2013-05-25 15:45:21 +0000
committerAndrej Zverev <az@FreeBSD.org>2013-05-25 15:45:21 +0000
commit4c1730a748d5360ef93e9edf1cb8c54829067b99 (patch)
treee1f527cb611da0133dcf0aa394aa20dce2098925 /textproc/p5-CSS-Compressor
parent7feebdcc7c15232d9c18080bb5fec201e0718431 (diff)
downloadports-4c1730a748d5360ef93e9edf1cb8c54829067b99.tar.gz
ports-4c1730a748d5360ef93e9edf1cb8c54829067b99.zip
Notes
Diffstat (limited to 'textproc/p5-CSS-Compressor')
-rw-r--r--textproc/p5-CSS-Compressor/Makefile4
-rw-r--r--textproc/p5-CSS-Compressor/files/csscompressor61
-rw-r--r--textproc/p5-CSS-Compressor/pkg-plist1
3 files changed, 66 insertions, 0 deletions
diff --git a/textproc/p5-CSS-Compressor/Makefile b/textproc/p5-CSS-Compressor/Makefile
index 26fcc177d895..98fd57f7a172 100644
--- a/textproc/p5-CSS-Compressor/Makefile
+++ b/textproc/p5-CSS-Compressor/Makefile
@@ -3,6 +3,7 @@
PORTNAME= CSS-Compressor
PORTVERSION= 0.02
+PORTREVISION= 1
CATEGORIES= textproc perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -12,6 +13,9 @@ COMMENT= Perl extension for CSS minification
PERL_CONFIGURE= yes
+post-install:
+ ${INSTALL_SCRIPT} ${FILESDIR}/csscompressor ${PREFIX}/bin
+
MAN3= CSS::Compressor.3
.include <bsd.port.mk>
diff --git a/textproc/p5-CSS-Compressor/files/csscompressor b/textproc/p5-CSS-Compressor/files/csscompressor
new file mode 100644
index 000000000000..9c1f604f39b7
--- /dev/null
+++ b/textproc/p5-CSS-Compressor/files/csscompressor
@@ -0,0 +1,61 @@
+#!/usr/local/bin/perl
+
+# Copyright (c) 2012, Gea-Suan Lin
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are met:
+#
+# 1. Redistributions of source code must retain the above copyright notice, this
+# list of conditions and the following disclaimer.
+# 2. Redistributions in binary form must reproduce the above copyright notice,
+# this list of conditions and the following disclaimer in the documentation
+# and/or other materials provided with the distribution.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND
+# ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
+# WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
+# DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR
+# ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
+# (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
+# LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
+# ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
+# SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+#
+# The views and conclusions contained in the software and documentation are those
+# of the authors and should not be interpreted as representing official policies,
+# either expressed or implied, of the FreeBSD Project.
+
+use strict;
+use warnings;
+
+use CSS::Compressor qw/css_compress/;
+use IO::File;
+use Getopt::Long;
+
+my $outfile;
+my $verbose = 0;
+
+GetOptions('output|o=s' => \$outfile, 'verbose|v' => \$verbose);
+
+my $infile = $ARGV[0];
+
+if (!defined $infile) {
+ die 'You need to specify input css file';
+}
+
+my $fh = IO::File->new($infile, 'r') or die $@;
+my $input = join '', <$fh>;
+$fh->close;
+
+my $output = css_compress $input;
+if (defined $outfile) {
+ my $fh = IO::File->new($outfile, 'w+') or die $@;
+ print $fh $output;
+ $fh->close;
+} else {
+ print $output;
+}
+
+__END__
diff --git a/textproc/p5-CSS-Compressor/pkg-plist b/textproc/p5-CSS-Compressor/pkg-plist
index 1695bad0087f..2ad0e5432c88 100644
--- a/textproc/p5-CSS-Compressor/pkg-plist
+++ b/textproc/p5-CSS-Compressor/pkg-plist
@@ -1,6 +1,7 @@
@comment $FreeBSD$
%%SITE_PERL%%/%%PERL_ARCH%%/auto/CSS/Compressor/.packlist
%%SITE_PERL%%/CSS/Compressor.pm
+bin/csscompressor
@dirrmtry %%SITE_PERL%%/CSS
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CSS/Compressor
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/CSS