aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-CSS-Tiny
diff options
context:
space:
mode:
authorLars Thegler <lth@FreeBSD.org>2005-04-02 10:41:56 +0000
committerLars Thegler <lth@FreeBSD.org>2005-04-02 10:41:56 +0000
commit5013c5fafeed7135ea1f3098dac369a2d9e8a0fa (patch)
tree89b607957a86d1ff7ffdfd744eaefa58aa78ca77 /textproc/p5-CSS-Tiny
parent153142767d5f248dc9a279e286994dfa076540ff (diff)
downloadports-5013c5fafeed7135ea1f3098dac369a2d9e8a0fa.tar.gz
ports-5013c5fafeed7135ea1f3098dac369a2d9e8a0fa.zip
Notes
Diffstat (limited to 'textproc/p5-CSS-Tiny')
-rw-r--r--textproc/p5-CSS-Tiny/Makefile21
-rw-r--r--textproc/p5-CSS-Tiny/distinfo6
-rw-r--r--textproc/p5-CSS-Tiny/files/500503-lib::CSS::Tiny.pm11
-rw-r--r--textproc/p5-CSS-Tiny/pkg-descr2
4 files changed, 34 insertions, 6 deletions
diff --git a/textproc/p5-CSS-Tiny/Makefile b/textproc/p5-CSS-Tiny/Makefile
index e5e609e0b0b8..8a2733aca4fa 100644
--- a/textproc/p5-CSS-Tiny/Makefile
+++ b/textproc/p5-CSS-Tiny/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= CSS-Tiny
-PORTVERSION= 1.05
-PORTREVISION= 1
+PORTVERSION= 1.08
CATEGORIES= textproc perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= CSS
@@ -19,4 +18,20 @@ COMMENT= Read/Write .css files with as little code as possible
PERL_CONFIGURE= yes
MAN3= CSS::Tiny.3
-.include <bsd.port.mk>
+post-patch:
+ @${RM} ${WRKSRC}/inc/Module/Install/AutoInstall.pm
+ @${PERL} -pi -e '$$_="" if /AutoInstall/' ${WRKSRC}/MANIFEST
+ @${PERL} -pi -e '$$_="" if /Test::More|auto_install/' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} <= 500503
+EXTRA_PATCHES= ${PATCHDIR}/500503-lib::CSS::Tiny.pm
+.endif
+
+.if ${PERL_LEVEL} < 500601
+BUILD_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+RUN_DEPENDS+= ${SITE_PERL}/File/Spec.pm:${PORTSDIR}/devel/p5-File-Spec
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-CSS-Tiny/distinfo b/textproc/p5-CSS-Tiny/distinfo
index 329b014c8764..f2e0ada35acf 100644
--- a/textproc/p5-CSS-Tiny/distinfo
+++ b/textproc/p5-CSS-Tiny/distinfo
@@ -1,2 +1,4 @@
-MD5 (CSS-Tiny-1.05.tar.gz) = f2a7d622e58c4cc0c6cad0d47b95d813
-SIZE (CSS-Tiny-1.05.tar.gz) = 14332
+MD5 (CSS-Tiny-1.08.tar.gz) = 0c045bfa699583267cf1321353d3b656
+SIZE (CSS-Tiny-1.08.tar.gz) = 21610
+MD5 (ExtUtils-AutoInstall-0.59.tar.gz) = 1dbcfe20069d125f5d2a0a351c2e9a57
+SIZE (ExtUtils-AutoInstall-0.59.tar.gz) = 25859
diff --git a/textproc/p5-CSS-Tiny/files/500503-lib::CSS::Tiny.pm b/textproc/p5-CSS-Tiny/files/500503-lib::CSS::Tiny.pm
new file mode 100644
index 000000000000..77532a46f17e
--- /dev/null
+++ b/textproc/p5-CSS-Tiny/files/500503-lib::CSS::Tiny.pm
@@ -0,0 +1,11 @@
+--- lib/CSS/Tiny.pm.orig Thu Mar 24 00:29:48 2005
++++ lib/CSS/Tiny.pm Thu Mar 24 00:29:59 2005
+@@ -209,7 +209,7 @@
+ my $file = shift or return $self->_error( 'No file name provided' );
+
+ # Write the file
+- open( CSS, '>', $file ) or return $self->_error( "Failed to open file '$file' for writing: $!" );
++ open( CSS, '>'. $file ) or return $self->_error( "Failed to open file '$file' for writing: $!" );
+ print CSS $self->write_string;
+ close( CSS );
+
diff --git a/textproc/p5-CSS-Tiny/pkg-descr b/textproc/p5-CSS-Tiny/pkg-descr
index ba3343ed69e6..96e83c4d28ab 100644
--- a/textproc/p5-CSS-Tiny/pkg-descr
+++ b/textproc/p5-CSS-Tiny/pkg-descr
@@ -5,6 +5,6 @@ This module is primarily for reading and writing simple files, and
anything we write shouldn't need to have documentation/comments. If you
need something with more power, move up to CSS.pm.
-WWW: http://search.cpan.org/search?dist=CSS-Tiny
+WWW: http://search.cpan.org/dist/CSS-Tiny
Hansjoerg Pehofer <hansjoerg.pehofer@uibk.ac.at>