aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Chess-PGN-Parse
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2005-08-31 11:11:35 +0000
committerRenato Botelho <garga@FreeBSD.org>2005-08-31 11:11:35 +0000
commit4ef9c6add42a9fc93d7be8240626fe287ff53662 (patch)
tree7c36bc502149b42ce6b83bad677ef15dd9fde5f2 /textproc/p5-Chess-PGN-Parse
parentaa36052f1c0600f32cade0dc85c1bffaa6269de8 (diff)
downloadports-4ef9c6add42a9fc93d7be8240626fe287ff53662.tar.gz
ports-4ef9c6add42a9fc93d7be8240626fe287ff53662.zip
Notes
Diffstat (limited to 'textproc/p5-Chess-PGN-Parse')
-rw-r--r--textproc/p5-Chess-PGN-Parse/Makefile28
-rw-r--r--textproc/p5-Chess-PGN-Parse/distinfo2
-rw-r--r--textproc/p5-Chess-PGN-Parse/pkg-descr24
-rw-r--r--textproc/p5-Chess-PGN-Parse/pkg-plist7
4 files changed, 61 insertions, 0 deletions
diff --git a/textproc/p5-Chess-PGN-Parse/Makefile b/textproc/p5-Chess-PGN-Parse/Makefile
new file mode 100644
index 000000000000..459358861b30
--- /dev/null
+++ b/textproc/p5-Chess-PGN-Parse/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Chess-PGN-Parse
+# Date created: 23 July 2005
+# Whom: Aaron Dalton <aaron@daltons.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Chess-PGN-Parse
+PORTVERSION= 0.18
+CATEGORIES= textproc games perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../authors/id/G/GM/GMAX
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= aaron@daltons.ca
+COMMENT= Reads and parses PGN (Portable Game Notation) Chess files
+
+PERL_CONFIGURE= yes
+
+MAN3= Chess::PGN::Parse.3
+
+.include <bsd.port.pre.mk>
+
+.if (${PERL_LEVEL} < 500600)
+BROKEN= "Require perl 5.6 or high"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Chess-PGN-Parse/distinfo b/textproc/p5-Chess-PGN-Parse/distinfo
new file mode 100644
index 000000000000..440a1597e810
--- /dev/null
+++ b/textproc/p5-Chess-PGN-Parse/distinfo
@@ -0,0 +1,2 @@
+MD5 (Chess-PGN-Parse-0.18.tar.gz) = 9c97380edd8f726719f0ae475c281b08
+SIZE (Chess-PGN-Parse-0.18.tar.gz) = 26356
diff --git a/textproc/p5-Chess-PGN-Parse/pkg-descr b/textproc/p5-Chess-PGN-Parse/pkg-descr
new file mode 100644
index 000000000000..5ca0a90bae54
--- /dev/null
+++ b/textproc/p5-Chess-PGN-Parse/pkg-descr
@@ -0,0 +1,24 @@
+Chess::PGN::Parse offers a range of methods to read and manipulate
+Portable Game Notation files. PGN files contain chess games produced by
+chess programs following a standard format
+(http://www.schachprobleme.de/chessml/faq/pgn/). It is among the preferred
+means of chess games distribution. Being a public, well established
+standard, PGN is understood by many chess archive programs. Parsing simple
+PGN files is not difficult. However, dealing with some of the intricacies
+of the Standard is less than trivial. This module offers a clean handle
+toward reading and parsing complex PGN files.
+
+A PGN file has several tags, which are key/values pairs at the header of
+each game, in the format [key "value"]
+
+After the header, the game follows. A string of numbered chess moves,
+optionally interrupted by braced comments and recursive parenthesized
+variants and comments. While dealing with simple braced comments is
+straightforward, parsing nested comments can give you more than a
+headache.
+
+WWW: http://search.cpan.org/dist/Chess-PGN-Parse
+Author: Giuseppe Maxia <gmax@cpan.org>
+
+- Aaron Dalton
+aaron@daltons.ca
diff --git a/textproc/p5-Chess-PGN-Parse/pkg-plist b/textproc/p5-Chess-PGN-Parse/pkg-plist
new file mode 100644
index 000000000000..9ddb2a4abac9
--- /dev/null
+++ b/textproc/p5-Chess-PGN-Parse/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Chess/PGN/Parse.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Chess/PGN/Parse/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Chess/PGN/Parse
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Chess/PGN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Chess 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Chess/PGN 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Chess 2>/dev/null || true