aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Class-CSV
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-12-25 07:45:49 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-12-25 07:45:49 +0000
commit7d9bf7d8d68bd6c990b6d44af43b0bd924f2063c (patch)
tree84f88bc8c680b6f371a6059c642fc3909eda85a4 /textproc/p5-Class-CSV
parent244bdf1b3748c92feeb548e61da04fa454aa6e4f (diff)
downloadports-7d9bf7d8d68bd6c990b6d44af43b0bd924f2063c.tar.gz
ports-7d9bf7d8d68bd6c990b6d44af43b0bd924f2063c.zip
Notes
Diffstat (limited to 'textproc/p5-Class-CSV')
-rw-r--r--textproc/p5-Class-CSV/Makefile26
-rw-r--r--textproc/p5-Class-CSV/distinfo3
-rw-r--r--textproc/p5-Class-CSV/pkg-descr6
-rw-r--r--textproc/p5-Class-CSV/pkg-plist5
4 files changed, 40 insertions, 0 deletions
diff --git a/textproc/p5-Class-CSV/Makefile b/textproc/p5-Class-CSV/Makefile
new file mode 100644
index 000000000000..5c623528c53a
--- /dev/null
+++ b/textproc/p5-Class-CSV/Makefile
@@ -0,0 +1,26 @@
+# ex:ts=8
+# Ports collection makefile for: Class::CSV
+# Date created: Dec 25, 2006
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-CSV
+PORTVERSION= 1.02
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Class based CSV parser/writer
+
+BUILD_DEPENDS= p5-Text-CSV_XS>=0.23:${PORTSDIR}/textproc/p5-Text-CSV_XS \
+ p5-Class-Accessor>=0.18:${PORTSDIR}/devel/p5-Class-Accessor
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::CSV.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Class-CSV/distinfo b/textproc/p5-Class-CSV/distinfo
new file mode 100644
index 000000000000..87f6db0bb169
--- /dev/null
+++ b/textproc/p5-Class-CSV/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-CSV-1.02.tar.gz) = f811bcae2de07df90898d0bc447a86e4
+SHA256 (Class-CSV-1.02.tar.gz) = 863f434ee46d95b8020b1cca4a690f0b5d1b468f3980a5eec7b396ffd327b1c0
+SIZE (Class-CSV-1.02.tar.gz) = 6257
diff --git a/textproc/p5-Class-CSV/pkg-descr b/textproc/p5-Class-CSV/pkg-descr
new file mode 100644
index 000000000000..9bd21fe6ed0d
--- /dev/null
+++ b/textproc/p5-Class-CSV/pkg-descr
@@ -0,0 +1,6 @@
+This module can be used to create objects from CSV files, or to create CSV
+files from objects. Text::CSV_XS is used for parsing and creating CSV file
+lines, so any limitations in Text::CSV_XS will of course be inherant in
+this module.
+
+WWW: http://search.cpan.org/dist/Class-CSV/
diff --git a/textproc/p5-Class-CSV/pkg-plist b/textproc/p5-Class-CSV/pkg-plist
new file mode 100644
index 000000000000..e5033d79abc2
--- /dev/null
+++ b/textproc/p5-Class-CSV/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/Class/CSV.pm
+@dirrmtry %%SITE_PERL%%/Class
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/CSV/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/CSV
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class