aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Data-Phrasebook-Loader-YAML
diff options
context:
space:
mode:
authorAnton Berezin <tobez@FreeBSD.org>2010-05-05 11:54:02 +0000
committerAnton Berezin <tobez@FreeBSD.org>2010-05-05 11:54:02 +0000
commit283dc769b07fdc67cb9439fba036f46c1033dc9f (patch)
tree176447d3ea2ce4a0691aca8c136b9e403b74d5de /textproc/p5-Data-Phrasebook-Loader-YAML
parent8dd8e19ea45d054a68e1cd71bb3d04f3c1d3c3af (diff)
downloadports-283dc769b07fdc67cb9439fba036f46c1033dc9f.tar.gz
ports-283dc769b07fdc67cb9439fba036f46c1033dc9f.zip
Notes
Diffstat (limited to 'textproc/p5-Data-Phrasebook-Loader-YAML')
-rw-r--r--textproc/p5-Data-Phrasebook-Loader-YAML/Makefile26
-rw-r--r--textproc/p5-Data-Phrasebook-Loader-YAML/distinfo3
-rw-r--r--textproc/p5-Data-Phrasebook-Loader-YAML/pkg-descr9
-rw-r--r--textproc/p5-Data-Phrasebook-Loader-YAML/pkg-plist9
4 files changed, 47 insertions, 0 deletions
diff --git a/textproc/p5-Data-Phrasebook-Loader-YAML/Makefile b/textproc/p5-Data-Phrasebook-Loader-YAML/Makefile
new file mode 100644
index 000000000000..2709c03ac7b8
--- /dev/null
+++ b/textproc/p5-Data-Phrasebook-Loader-YAML/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: textproc/p5-Data-Phrasebook-Loader-YAML
+# Date created: 05 May 2010
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Data-Phrasebook-Loader-YAML
+PORTVERSION= 0.09
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Data
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= A loader class for phrasebook implementations using YAML
+
+BUILD_DEPENDS= ${SITE_PERL}/YAML.pm:${PORTSDIR}/textproc/p5-YAML \
+ ${SITE_PERL}/Data/Phrasebook.pm:${PORTSDIR}/textproc/p5-Data-Phrasebook
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Data::Phrasebook::Loader::YAML.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Data-Phrasebook-Loader-YAML/distinfo b/textproc/p5-Data-Phrasebook-Loader-YAML/distinfo
new file mode 100644
index 000000000000..80c7f05dc25d
--- /dev/null
+++ b/textproc/p5-Data-Phrasebook-Loader-YAML/distinfo
@@ -0,0 +1,3 @@
+MD5 (Data-Phrasebook-Loader-YAML-0.09.tar.gz) = 74e57c267c2a94fad12c1efce0841ab7
+SHA256 (Data-Phrasebook-Loader-YAML-0.09.tar.gz) = e59e984a0a23fb6402336b440bba04e89e3d1e72c71cd941f782d8ad8a212c52
+SIZE (Data-Phrasebook-Loader-YAML-0.09.tar.gz) = 17740
diff --git a/textproc/p5-Data-Phrasebook-Loader-YAML/pkg-descr b/textproc/p5-Data-Phrasebook-Loader-YAML/pkg-descr
new file mode 100644
index 000000000000..c205287e7524
--- /dev/null
+++ b/textproc/p5-Data-Phrasebook-Loader-YAML/pkg-descr
@@ -0,0 +1,9 @@
+This class loader implements phrasebook patterns using YAML.
+
+Phrases can be contained within one or more dictionaries, with each phrase
+accessible via a unique key. Phrases may contain placeholders, please see
+Data::Phrasebook for an explanation of how to use these. Groups of phrases are
+kept in a dictionary. In this implementation a single file is one complete
+dictionary.
+
+WWW: http://search.cpan.org/dist/Data-Phrasebook-Loader-YAML/
diff --git a/textproc/p5-Data-Phrasebook-Loader-YAML/pkg-plist b/textproc/p5-Data-Phrasebook-Loader-YAML/pkg-plist
new file mode 100644
index 000000000000..8a359a981875
--- /dev/null
+++ b/textproc/p5-Data-Phrasebook-Loader-YAML/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/Data/Phrasebook/Loader/YAML.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Phrasebook/Loader/YAML/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Phrasebook/Loader/YAML
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Phrasebook/Loader
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data/Phrasebook
+@dirrmtry %%SITE_PERL%%/Data/Phrasebook/Loader
+@dirrmtry %%SITE_PERL%%/Data/Phrasebook
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Data
+@dirrmtry %%SITE_PERL%%/Data