aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-File-Inplace
diff options
context:
space:
mode:
authorGreg Larkin <glarkin@FreeBSD.org>2010-12-08 21:03:20 +0000
committerGreg Larkin <glarkin@FreeBSD.org>2010-12-08 21:03:20 +0000
commit9e74af8f588272a0ee55cf151244b65faeff67f7 (patch)
tree87542a7eaa63dc299ca30cacfd272135a30f61aa /textproc/p5-File-Inplace
parent9fc3722c418152bb90f736c2696b400f7ff07770 (diff)
downloadports-9e74af8f588272a0ee55cf151244b65faeff67f7.tar.gz
ports-9e74af8f588272a0ee55cf151244b65faeff67f7.zip
Notes
Diffstat (limited to 'textproc/p5-File-Inplace')
-rw-r--r--textproc/p5-File-Inplace/Makefile21
-rw-r--r--textproc/p5-File-Inplace/distinfo2
-rw-r--r--textproc/p5-File-Inplace/pkg-descr12
-rw-r--r--textproc/p5-File-Inplace/pkg-plist4
4 files changed, 39 insertions, 0 deletions
diff --git a/textproc/p5-File-Inplace/Makefile b/textproc/p5-File-Inplace/Makefile
new file mode 100644
index 000000000000..a7b3b589adef
--- /dev/null
+++ b/textproc/p5-File-Inplace/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: File-Inplace
+# Date created: 2010-12-08
+# Whom: Greg Larkin <glarkin@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Inplace
+PORTVERSION= 0.20
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= glarkin@FreeBSD.org
+COMMENT= Perl module for in-place editing of files
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Inplace.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-File-Inplace/distinfo b/textproc/p5-File-Inplace/distinfo
new file mode 100644
index 000000000000..bfe652a9d889
--- /dev/null
+++ b/textproc/p5-File-Inplace/distinfo
@@ -0,0 +1,2 @@
+SHA256 (File-Inplace-0.20.tar.gz) = 00d63cf15fdd03a166ecb7af2813a684251254f992fcf5da722ff557b4f10a3e
+SIZE (File-Inplace-0.20.tar.gz) = 5139
diff --git a/textproc/p5-File-Inplace/pkg-descr b/textproc/p5-File-Inplace/pkg-descr
new file mode 100644
index 000000000000..a2b4c36106d5
--- /dev/null
+++ b/textproc/p5-File-Inplace/pkg-descr
@@ -0,0 +1,12 @@
+File::Inplace is a Perl module intended to ease the common task of
+editing a file in-place. Inspired by variations of Perl's -i option,
+this module is intended for somewhat more structured and reusable
+editing than command line Perl typically allows.
+
+File::Inplace endeavors to guarantee file integrity; that is, either
+all of the changes made will be saved to the file, or none will.
+It also offers functionality such as backup creation, automatic
+field splitting per-line, automatic chomping/unchomping, and aborting
+edits partially through without affecting the original file.
+
+WWW: http://search.cpan.org/dist/File-Inplace/
diff --git a/textproc/p5-File-Inplace/pkg-plist b/textproc/p5-File-Inplace/pkg-plist
new file mode 100644
index 000000000000..eb89e9aae366
--- /dev/null
+++ b/textproc/p5-File-Inplace/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/File/Inplace.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Inplace/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Inplace
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File