aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-Google-Data-JSON/Makefile
diff options
context:
space:
mode:
authorChin-San Huang <chinsan@FreeBSD.org>2007-07-28 14:17:21 +0000
committerChin-San Huang <chinsan@FreeBSD.org>2007-07-28 14:17:21 +0000
commit976cadd0a261454fb978cd2749d636ad460ffcb0 (patch)
tree4bb74d6d307c2069a72b5df9c38578050dbc714e /textproc/p5-Google-Data-JSON/Makefile
parentc5f3f70024b2636bdb07bdabc85d5c30115bf668 (diff)
downloadports-976cadd0a261454fb978cd2749d636ad460ffcb0.tar.gz
ports-976cadd0a261454fb978cd2749d636ad460ffcb0.zip
Notes
Diffstat (limited to 'textproc/p5-Google-Data-JSON/Makefile')
-rw-r--r--textproc/p5-Google-Data-JSON/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/textproc/p5-Google-Data-JSON/Makefile b/textproc/p5-Google-Data-JSON/Makefile
new file mode 100644
index 000000000000..4ce5b9028727
--- /dev/null
+++ b/textproc/p5-Google-Data-JSON/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: p5-Google-Data-JSON
+# Date created: 2007/07/28
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Google-Data-JSON
+PORTVERSION= 0.1.3
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= HTML/TAKERU
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= General XML-JSON converter based on Google Data APIs
+
+BUILD_DEPENDS= p5-File-Slurp>=0:${PORTSDIR}/devel/p5-File-Slurp \
+ p5-Perl6-Export-Attrs>=0:${PORTSDIR}/devel/p5-Perl6-Export-Attrs \
+ p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings \
+ p5-UNIVERSAL-require>=0:${PORTSDIR}/devel/p5-UNIVERSAL-require \
+ p5-version>=0:${PORTSDIR}/devel/p5-version \
+ p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Test-Perl-Critic>=0:${PORTSDIR}/textproc/p5-Test-Perl-Critic \
+ p5-XML-Atom>=0:${PORTSDIR}/textproc/p5-XML-Atom \
+ p5-XML-Simple>=0:${PORTSDIR}/textproc/p5-XML-Simple \
+ p5-YAML-Syck>=0:${PORTSDIR}/textproc/p5-YAML-Syck
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Google::Data::JSON.3
+
+.include <bsd.port.mk>