aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-HTML-HTML5-Parser
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-07-02 08:54:56 +0000
committerWen Heping <wen@FreeBSD.org>2010-07-02 08:54:56 +0000
commit9f550f23365f6c38f1117a96645417acfb392f89 (patch)
treed7db36b5b7a8e75c2eabf493ce6ca6952c9e1b2a /textproc/p5-HTML-HTML5-Parser
parent03cae8de77c3c75b1e41aace891e18cdd0e799ac (diff)
downloadports-9f550f23365f6c38f1117a96645417acfb392f89.tar.gz
ports-9f550f23365f6c38f1117a96645417acfb392f89.zip
Notes
Diffstat (limited to 'textproc/p5-HTML-HTML5-Parser')
-rw-r--r--textproc/p5-HTML-HTML5-Parser/Makefile29
-rw-r--r--textproc/p5-HTML-HTML5-Parser/distinfo3
-rw-r--r--textproc/p5-HTML-HTML5-Parser/pkg-descr11
-rw-r--r--textproc/p5-HTML-HTML5-Parser/pkg-plist19
4 files changed, 62 insertions, 0 deletions
diff --git a/textproc/p5-HTML-HTML5-Parser/Makefile b/textproc/p5-HTML-HTML5-Parser/Makefile
new file mode 100644
index 000000000000..e02c7f2bc7ec
--- /dev/null
+++ b/textproc/p5-HTML-HTML5-Parser/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-HTML-HTML5-Parser
+# Date created: July 02 2010
+# Whom: jupengfei <jupengfei@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML-HTML5-Parser
+PORTVERSION= 0.101
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= jupengfei@gmail.com
+COMMENT= A named entity list for HTML parser
+
+BUILD_DEPENDS= p5-Error>0:${PORTSDIR}/lang/p5-Error \
+ p5-Test-Simple>0:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-HTML-Encoding>=0.55:${PORTSDIR}/www/p5-HTML-Encoding \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-XML-LibXML>0:${PORTSDIR}/textproc/p5-XML-LibXML
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= HTML::HTML5::Parser.3 \
+ HTML::HTML5::Parser::NamedEntityList.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-HTML-HTML5-Parser/distinfo b/textproc/p5-HTML-HTML5-Parser/distinfo
new file mode 100644
index 000000000000..84585e7ea200
--- /dev/null
+++ b/textproc/p5-HTML-HTML5-Parser/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-HTML5-Parser-0.101.tar.gz) = 134e1e09da356f4c4eab104ff029ecd0
+SHA256 (HTML-HTML5-Parser-0.101.tar.gz) = bb682767832b04891d3b3899142cc8f83facb461eefe64e030f5186fa4fc1d15
+SIZE (HTML-HTML5-Parser-0.101.tar.gz) = 118482
diff --git a/textproc/p5-HTML-HTML5-Parser/pkg-descr b/textproc/p5-HTML-HTML5-Parser/pkg-descr
new file mode 100644
index 000000000000..e1479d3b61fe
--- /dev/null
+++ b/textproc/p5-HTML-HTML5-Parser/pkg-descr
@@ -0,0 +1,11 @@
+HTML::HTML5::Parse is substantially the same as the non-CPAN module
+Whatpm::HTML. Changes include:
+ * Provides an XML::LibXML-like DOM interface. If you usually use
+XML::LibXML's DOM parser, this should be a drop-in solution for tag
+soup HTML.
+ * Constructs an XML::LibXML::Document as the result of parsing.
+ * Via bundling and modifications, removed external dependencies
+on non-CPAN packages.
+
+
+WWW: http://search.cpan.org/dist/HTML-HTML5-Parser/
diff --git a/textproc/p5-HTML-HTML5-Parser/pkg-plist b/textproc/p5-HTML-HTML5-Parser/pkg-plist
new file mode 100644
index 000000000000..0ff60b06c09b
--- /dev/null
+++ b/textproc/p5-HTML-HTML5-Parser/pkg-plist
@@ -0,0 +1,19 @@
+bin/html2xhtml
+%%SITE_PERL%%/HTML/HTML5/Parser/Charset/UnicodeChecker.pm
+%%SITE_PERL%%/HTML/HTML5/Parser/Charset/Info.pm
+%%SITE_PERL%%/HTML/HTML5/Parser/Charset/UniversalCharDet.pm
+%%SITE_PERL%%/HTML/HTML5/Parser/Charset/WebThai.pm
+%%SITE_PERL%%/HTML/HTML5/Parser/Charset/DecodeHandle.pm
+%%SITE_PERL%%/HTML/HTML5/Parser/Charset/WebLatin1.pm
+%%SITE_PERL%%/HTML/HTML5/Parser/TagSoupParser.pm
+%%SITE_PERL%%/HTML/HTML5/Parser/Tokenizer.pm
+%%SITE_PERL%%/HTML/HTML5/Parser/NamedEntityList.pm
+%%SITE_PERL%%/HTML/HTML5/Parser.pm
+%%SITE_PERL%%/mach/auto/HTML/HTML5/Parser/.packlist
+@dirrm %%SITE_PERL%%/HTML/HTML5/Parser/Charset
+@dirrm %%SITE_PERL%%/HTML/HTML5/Parser
+@dirrmtry %%SITE_PERL%%/HTML/HTML5
+@dirrmtry %%SITE_PERL%%/HTML
+@dirrm %%SITE_PERL%%/mach/auto/HTML/HTML5/Parser
+@dirrmtry %%SITE_PERL%%/mach/auto/HTML/HTML5
+@dirrmtry %%SITE_PERL%%/mach/auto/HTML