aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-HTML-RewriteAttributes
diff options
context:
space:
mode:
authorPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-07-28 19:00:24 +0000
committerPhilip M. Gollucci <pgollucci@FreeBSD.org>2008-07-28 19:00:24 +0000
commit06b2f8f373fb330d2bc08b3840ecbab4eff476e4 (patch)
treeb8bf3ae5579609696fad6e6ff0dbc88e7494b56e /textproc/p5-HTML-RewriteAttributes
parent2611a9dec9312a6d77b5b10339cb568a830bb0d7 (diff)
Notes
Diffstat (limited to 'textproc/p5-HTML-RewriteAttributes')
-rw-r--r--textproc/p5-HTML-RewriteAttributes/Makefile32
-rw-r--r--textproc/p5-HTML-RewriteAttributes/distinfo3
-rw-r--r--textproc/p5-HTML-RewriteAttributes/pkg-descr6
3 files changed, 41 insertions, 0 deletions
diff --git a/textproc/p5-HTML-RewriteAttributes/Makefile b/textproc/p5-HTML-RewriteAttributes/Makefile
new file mode 100644
index 000000000000..23bebc744554
--- /dev/null
+++ b/textproc/p5-HTML-RewriteAttributes/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: p5-HTML-Attributes
+# Date created: 2008/08/24
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+
+PORTNAME= HTML-RewriteAttributes
+PORTVERSION= 0.03
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= Simple yet powerful HTML attribute rewriting
+
+MAN3= HTML::RewriteAttributes::Resources.3 \
+ HTML::RewriteAttributes::Links.3 \
+ HTML::RewriteAttributes.3
+
+PERL_CONFIGURE= yes
+
+PLIST_FILES= %%SITE_PERL%%/HTML/RewriteAttributes.pm \
+ %%SITE_PERL%%/HTML/RewriteAttributes/Resources.pm \
+ %%SITE_PERL%%/HTML/RewriteAttributes/Links.pm \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/RewriteAttributes/.packlist
+
+PLIST_DIRS= %%SITE_PERL%%/HTML/RewriteAttributes \
+ %%SITE_PERL%%/HTML \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML/RewriteAttributes \
+ %%SITE_PERL%%/%%PERL_ARCH%%/auto/HTML
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-HTML-RewriteAttributes/distinfo b/textproc/p5-HTML-RewriteAttributes/distinfo
new file mode 100644
index 000000000000..3b19b159dbb9
--- /dev/null
+++ b/textproc/p5-HTML-RewriteAttributes/distinfo
@@ -0,0 +1,3 @@
+MD5 (HTML-RewriteAttributes-0.03.tar.gz) = 7580f6d63b171b318547d5ef4138ce34
+SHA256 (HTML-RewriteAttributes-0.03.tar.gz) = 3d2fab5d2143cd489363731750a84da2992a17135cc17c12817bb18ae68745db
+SIZE (HTML-RewriteAttributes-0.03.tar.gz) = 18148
diff --git a/textproc/p5-HTML-RewriteAttributes/pkg-descr b/textproc/p5-HTML-RewriteAttributes/pkg-descr
new file mode 100644
index 000000000000..6d57f1073923
--- /dev/null
+++ b/textproc/p5-HTML-RewriteAttributes/pkg-descr
@@ -0,0 +1,6 @@
+HTML::RewriteAttributes is designed for simple yet powerful HTML
+attribute rewriting. You simply specify a callback to run for each
+attribute and we do the rest for you. This module is designed to
+be subclassable to make handling special cases eaiser.
+
+WWW: http://search.cpan.org/dist/HTML-RewriteAttributes/