aboutsummaryrefslogtreecommitdiff
path: root/textproc/p5-HTML-Tidy/Makefile
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-09-23 20:15:49 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2013-09-23 20:15:49 +0000
commit76063e5e67b4b05c8124511a5a0be50f6e13dc8e (patch)
tree68bb93539cd77e970e3dddae840d1db557578350 /textproc/p5-HTML-Tidy/Makefile
parent3f5f3d4a1a4e83926c7ca0dc249956b3a3dd0bc4 (diff)
downloadports-76063e5e67b4b05c8124511a5a0be50f6e13dc8e.tar.gz
ports-76063e5e67b4b05c8124511a5a0be50f6e13dc8e.zip
Notes
Diffstat (limited to 'textproc/p5-HTML-Tidy/Makefile')
-rw-r--r--textproc/p5-HTML-Tidy/Makefile30
1 files changed, 18 insertions, 12 deletions
diff --git a/textproc/p5-HTML-Tidy/Makefile b/textproc/p5-HTML-Tidy/Makefile
index 9f3f0182fefe..aec8a073ce45 100644
--- a/textproc/p5-HTML-Tidy/Makefile
+++ b/textproc/p5-HTML-Tidy/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= HTML-Tidy
-PORTVERSION= 1.54
+PORTVERSION= 1.56
CATEGORIES= textproc www perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
@@ -11,26 +11,32 @@ MAINTAINER= perl@FreeBSD.org
COMMENT= Web validation in a Perl object using tidy
BUILD_DEPENDS= p5-libwww>=0:${PORTSDIR}/www/p5-libwww
-LIB_DEPENDS= tidyp:${PORTSDIR}/textproc/tidyp
+LIB_DEPENDS= libtidyp.so:${PORTSDIR}/textproc/tidyp
RUN_DEPENDS:= ${BUILD_DEPENDS}
+OPTIONS_DEFINE= DOCS
+
USES= perl5
USE_PERL5= configure
-MAN3= HTML::Tidy.3 HTML::Tidy::Message.3
+PORTDOCS= Changes README.markdown
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' \
- ${WRKSRC}/Makefile.PL
+.include <bsd.port.options.mk>
-.if !defined(NOPORTDOCS)
-PORTDOCS= Changes README.markdown
+post-patch:
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/Makefile.PL
post-install:
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}/
+ cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR}/
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501400
+TEST_DEPENDS+= p5-Test-Simple>=0.98:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
+.include <bsd.port.post.mk>